0

I'm trying to set up a web app, but I keep on getting errors.

If I try in the portal I keep on seeing that the status is "deleted" and the deployment failed because application insights is not supported in my region.

I do not need application insights.

In Visual Studio I get the following error

--------------------------- Microsoft Visual Studio --------------------------- Following errors occured during the deployment:

Error during deployment for resource 'AppInsightsComponents MySite' in resource group 'MegaSale': MissingRegistrationForLocation: The subscription is not registered for the resource type 'components' in the location 'Central US'. Please re-register for this provider in order to have access to this location..

Error during deployment for resource 'MySite' in resource group 'MegaSale': NoRegisteredProviderFound: No registered resource provider found for location 'West Europe' and API version '2.0' for type 'servers'. The supported api-versions are '2014-01-01, 2014-04-01, 2014-04-01-preview'. The supported locations are 'centralus, eastus, westus, southcentralus, eastus2, northcentralus, eastasia, southeastasia, japanwest, japaneast, northeurope, westeurope, brazilsouth, australiaeast, australiasoutheast, centralindia, westindia, southindia, canadacentral, canadaeast, westus2, westcentralus, uksouth, ukwest'..

and this occurs no matter which region I choose.

I would like to use Western Europe, but can accept a different region if it would just work.

I don't mind scraping my whole subscription and starting anew, though I'd rather not if possible.

The resource group I certainly don't mind trashing totally.

0

I had the same problem today. The only way I could bypass this was:

  1. Create a new web application on https://portal.azure.com
  2. Change "Application Insights" in Monitoring Section of the new web app to force it to one of the available zones (in dropdown list)
  3. Export the publishing setting for this web app
  4. In Visual studio, publish the application importing the above publishing settings instead using Azure publishing options
0

in the end it was solved only by opening a ticket with microsoft, for posterity i postiing their summary of the case

Issue Definition: You are unable to create and Publish Web Apps from Visual Studio 2015 Update 3. You got multiple issues including Publish wizard not showing existing web apps in the list. Then you had exception “The type initializer for 'Microsoft.Web.Microsoft.Web.Deployment.DeploymentManager' threw an exception. The type initializer for 'Microsoft.Web.Microsoft.Web.Deployment.BuiltinTypesCache' threw an exception”. Then you had problems with connection string.

Environment Visual Studio 2015 Update 3 Community Edition Azure App Service Tools v2.9.6 14.0.21111.0 Azure App Service Tools v2.9.6 Windows 7 SP1 x64 Scope Agreement: We will help you to know “Why you are unable to create and Publish Web Apps from Visual Studio 2015 Update 3. And why you got multiple issues including Publish wizard not showing existing web apps in the list. Then you had exception “The type initializer for 'Microsoft.Web.Microsoft.Web.Deployment.DeploymentManager' threw an exception. The type initializer for 'Microsoft.Web.Microsoft.Web.Deployment.BuiltinTypesCache' threw an exception”. Then you had problems with connection string.? “

Solution: First we cleared all the existing Web Apps and Resource Groups. Next, we installed the latest version of Azure SDK 2.9.6 on your Visual Studio Box. Then we followed the suggestions documented at https://stackoverflow.com/questions/6351289/web-deployment-task-failed-the-type-initializer-for-microsoft-web-deployment . Then, we were able to create and publish web apps and we decided to close the case.

i will just add, that they also made some changes to the registry, some key about "extensibility"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.