0

Hopefully somebody will be able to assist me in troubleshooting. I am trying to draw a CPU utilization graph for 2 Dell Powerconnect 8024F switches using a custom graph template that calls a Perl script. The script works well when called from the command line, but graphs don't get created in Cacti. The log message describing the problem is this:

POLLER: Poller[0] WARNING: Poller Output Table not Empty. Issues Found: 6, Data Sources: (DS[134]), (DS[135]), (DS[136]), (DS[137]), (DS[138]), (DS[139])

(BTW, RRD files don't get created; there has to be 6 of them - 3 for each of our 2 switches) The problem does not happen with other graphs that do not utilize scripts.

The initial poller was Spine, later it was changed to cmd.php with no difference. What I've tried is: 1) changed polling interval to 1 minute (in Cacti's GUI and in crontab); 2) manually created RRD files via Debug Data Source. Graphs appeared, but values were NaN, and RRD files never got updated. 3) manually truncated the table "poller_output". It got populated the next cycle. 4) changed the string in the Data Input Method from

perl <path_cacti>/scripts/62xx_cpu.pl -H <ip> -C <co> -version <ve> -port <port> -domain <do> -user <user> -pass <pass> -authprotocol <ap> -privatepassword <pp> -privateprotocol <ppo> -timeout <ti>

to

perl /usr/share/cacti/scripts/62xx_cpu.pl -H <ip>

and even to

/usr/bin/perl /var/lib/cacti/scripts/62xx_cpu.pl -H <ip>

(to eliminate implicit paths and links)

(I've added my community string directly in the script; the script returns values when called from the command line.) 5) changed PHP memory limit from 64M to 1024M; 6) changed the poller from Spine to cmd.

No luck so far.

Here's some info about my setup:

Technical Support

General Information Date Mon, 12 Dec 2016 11:55:47 +0400 Cacti Version 0.8.8h Cacti OS unix SNMP Version NET-SNMP version: 5.7.2 RRDTool Version RRDTool 1.4.x Hosts 3 Graphs 69 Data Sources Script/Command: 11 SNMP: 6 SNMP Query: 59 Total: 76

Poller Information Interval 300 Type cmd.php Items Action[0]: 124 Action[1]: 11 Total: 135 Concurrent Processes 1 Max Threads 1 PHP Servers 1 Script Timeout 25 Max OID 10 Last Run Statistics Time:1.0357 Method:spine Processes:1 Threads:1 Hosts:4 HostsPerProcess:4 DataSources:131 RRDsProcessed:66

PHP Information PHP Version 5.4.16 PHP OS Linux PHP uname Linux SRV-GILAN-LOG02 3.10.0-327.el7.x86_64 #1 SMP Thu Nov 19 22:10:57 UTC 2015 x86_64 PHP SNMP Installed max_execution_time 30 memory_limit 1024M

Please advise - what I should try next? Thank you in advance for any assistance.

0

Solved it myself. Here's the link for the details: http://forums.cacti.net/viewtopic.php?f=21&t=56659

  • What was the solution? Linking to another forum doesn't help people here. – Starfish May 22 '17 at 17:36
  • The solution was to modify the Perl script, because its ending had no connection with the output fields expected by the associated graph template. This was rather strange, because both the script and the template were downloaded from the official Cacti site. – Orkhan Gasimov May 23 '17 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.