I have the following setup: -Domain environment -Firewall -Servers running Windows server 2012 -Web Application installed on IIS on a web server

Now, the application should be accessible from both local network and internet, but I am facing a problem with that. The application is accessible from the internet via the URL: "https://support.mydomain.com:8089/myapp" which is correct. But it is not accessible from the local network via this URL. Instead, it is accessible via the server local IP as following: http://172.x.x.x:8089/myapp/

When I run "nslookup support.mydomain" it resolved the public IP address. How can I access this app from both local network and internet via the public URL

Thanks in advance.

  • Where is the web server? In the DMZ? Does you internal DNS know the CNAME of the webserver for the local IP address? – hot2use Dec 20 '16 at 14:29

Create on your domain server the zone mydomain.com, and add the a name entry support <=> 172.x.x.x.

If it's only to test your website, you can add the host support.mydomain.com in your local host file.


Depending on your firewall, you likely do not have a loopback/return setup. You could resolve two ways.

  1. Create a DNS zone on your DNS server pointing your public DNS names to internal IP addresses. This is considered a split-scope DNS.

  2. On your firewall, you can create a loopback NAT policy to allow internal IPs to point to your Public IP and the firewall will point it back to the correct server IP. I've done this in firewalls like Cisco and Sonicwall. If you can tell us what kind of firewall you have, I can give you the layout of how to create this NAT policy. This will allow you to continue to use public DNS resolution for your public sites.

Sonicwall config: Original Source=Firewalled Subnets; Translated Source=Website Public IP; Original Destination=Website Public IP; Translated Destination=Webserver Internal IP; Original Service=8089; Translated Service=Original

  • Thanks for your response Gibson. We use Fortigate firewall. I will be very grateful If you can tell me how to configure it. – Anas Dec 16 '16 at 15:50
  • I'm not strong on Fortigate. I'll do some research and try to get back. – Jarrod L. J. Gibson Dec 21 '16 at 17:59

You have port forwarding set up in your router to access this site from the internet. The port forwarding instruction should also include a loop back option to allow the router to forward local requests back to local servers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.