0

McAfee expired on one of my workstations. I uninstalled it. (Happy to see it go)

Now my file and printer sharing does not work on that workstation. I have turned on all of the inbound rules in the firewall, and it still does not work. I also ran the Mcafee uninstaller to clean up leftovers. Still nothing.

The only way to get it working is to turn off the firewall entirely.

Any ideas on things I'm missing?

  • What do you mean you turned on the firewall rules? They're either enabled and allowing the traffic or they're disabled and disallowing the traffic. There's no on or off. Can you clarify? – joeqwerty Dec 15 '16 at 18:24
  • Allow inbound traffic for file and printer sharing (and ping) – pStan Dec 15 '16 at 18:25
  • So you have shared folders/printers on this workstation and you're unable to connect to them from other systems? – joeqwerty Dec 15 '16 at 18:32
  • Yes. Mainly I'm after the printer sharing... which worked fine before Mcafee started the "trial expired meltdown"... – pStan Dec 15 '16 at 18:35
2

Try netsh advfirewall reset command in cmd(admin). It will reset all the settings to default. If you still face the same problem, let us know.

  • Good Idea. Thanks. Tried it, but no ping response, and no printing until I turned the firewall back off. – pStan Dec 15 '16 at 18:41
  • Which version of windows is it? – Meet Gill Dec 15 '16 at 18:52
  • Windows 7 connecting to Windows 10 (Both Pro Versions) – pStan Dec 15 '16 at 18:57
0

Figured it out.

I had to change the scope on the firewall rule to allow the ping and file/printer sharing traffic from a different subnet since I was accessing across the VPN.

I should have mentioned the VPN part.

Thanks for all of the help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.