0

I have a debian instance on Google cloud. I needed to host a Play! Framework project. For this I installed a software Activator and added it to path as follows

export PATH=/home/user/activator-dist-1.3.12/bin:$PATH

All is well, activator gets added. I wire in my project fro GIT and start the Play! server.

I test APIs with POST MAN and its working. So I exit from Putty.

Next time, I login to Putty again and eagerly type the "activator" command in shell, and it tells me "Command not found".

I check the $PATH with echo and see that it has been reset to its initial value and does not contain activator/bin path.

Could someone help me with this issue.

1

Changing the var with the export command will only change it for that session. You can set your PATH environment var in the /etc/environment file. It will then be permanently set for all users.

  • I tried as you suggested. When I modified environment file, I was connected through Putty. I added the line export PATH=/home/user/activator-dist-1.3.12/bin:$PATH to the end of environment file. But when i type activator command it says "Command not found". But typing export PATH=/home/user/activator-dist-1.3.12/bin:$PATH in shell works. Why could this be happening? – Shabin Muhammed Dec 17 '16 at 6:38
  • You should remove 'export' from the /etc/environment file. So it should say "PATH=/home/user/activator-dist-1.3.12/bin:$PATH" – Lennert Kuijpers Dec 19 '16 at 11:06
  • Removed the word export. Still the same. Its not being added to PATH. Is it different for Debian? – Shabin Muhammed Dec 20 '16 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.