1

Took over a few Oracle Linux VMs from another team and found this weird situation. The /scratch is mounted on a logical volume according to them, but seems that the system is having some error and the corresponding LV is actually missing.

# df -h | grep scratch
/dev/mapper/vg01-lv_scratch
                       98G  696M   92G   1% /scratch

But lvs doesn't show this vg01-lv_scratch while it's supposed to, compared to some normal status hosts.

lvs
  LV      VG   Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  lv_root vg00 -wi-ao---- 51.00g
  lv_swap vg00 -wi-ao----  8.00g

The folder itself works fine right now, but when we tried to reboot one of the VM, and it'll fail to find /dev/mapper/vg01-lv_scratch to mount.

I'm curious how it can end up like this? If the LV is missing, shouldn't the mounted file-system stop working as well? If it's still working fine, where exactly it is mounted at and where can we find the data? Or fix this situation?

  • Have you tried: lvs vg01? It may be the vg00 is the default for the command. – mdpc Dec 20 '16 at 23:40
  • No luck. Looks like vg01 is really not there, as a reboot will fail when the system will try to mount back vg01-lv_scratch. But if we leave the VM there for now it'll work, kinda like in a limbo state. – Derek Dec 21 '16 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.