0

We have an Apache (IBM HTTP Server that is a fork of Apache: http://www-03.ibm.com/software/products/en/http-servers) server that runs virtual hosts that listen to port 80, 8000, and others (this for IBM WebSphere Commerce).

Port 80 is working fine, however port 8000 has stopped working. I've tried restarting the server, but no luck. wget -O - http://apacheserver:8000/

Resolving apacheserver... 10.39.21.55
Connecting to apacheserver|10.39.21.55|:8000... connected.
HTTP request sent, awaiting response... 200 No headers, assuming HTTP/0.9
Length: unspecified
Saving to: “STDOUT”

    [ <=>                                                                                                                                                                      ] 5           --.-K/s   in 0s      ▒

2016-12-22 14:40:11 (1.26 MB/s) - Read error at byte 5 (Connection reset by peer).Retrying.

Even when I'm on the machine itself, no luck. I've tried curl, same issues. I'm not a SysAdmin, just a lowly developer who has to deal with this since our SysAdmin is no longer with us, so I'm not sure what's going on here. I've tried opening up iptables, here's how they look:

apacheserver:~ # iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
apacheserver:~ # iptables -S
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT

To me it seems Apache is acting up, but I'm not even sure of that.

What should my next step be at this point?

1
  • "byte 5" is interesting, that's the length of an SSL record header. Can you show your Listen and virtualhost+contents? How about lsof -i :8000 (as root) as well?
    – covener
    Dec 22, 2016 at 22:15

1 Answer 1

0

Can you please post the last 100 lines of your httpd access log and error log? Can you also post your httpd.conf and site.conf?

All that you're telling us is that you can't connect on port 8000 and that your firewall rules shouldn't be blocking it.

You may want to try stopping apparmor and iptables. Try your test again with them shut off. If it works, then look at the config for those. If it doesn't, give us more data.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.