I'm trying to install Zenoss core 4.2.3 which requires RRDtool 1.4.7. CentOS 6 comes with RRDtool 1.3.8

So, I've downloaded the RPM rrdtool-1.4.7-1.el6.rfx.x86_64.rpm and tried to install it, which gave me the following output:

[root@automation-zenoss tmp]# rpm -i rrdtool-1.4.7-1.el6.rfx.x86_64.rpm
error: Failed dependencies:
libdbi.so.0()(64bit) is needed by rrdtool-1.4.7-1.el6.rfx.x86_64
perl(RRDp) is needed by rrdtool-1.4.7-1.el6.rfx.x86_64
perl(RRDs) is needed by rrdtool-1.4.7-1.el6.rfx.x86_64
perl(Time::HiRes) is needed by rrdtool-1.4.7-1.el6.rfx.x86_64

So I've downloaded perl-rrdtool-1.4.7-1.el6.rfx.x86_64.rpm and tried to install it which gave me the following output:

[root@automation-zenoss tmp]# rpm -i perl-rrdtool-1.4.7-1.el6.rfx.x86_64.rpm
error: Failed dependencies:
rrdtool = 1.4.7 is needed by perl-rrdtool-1.4.7-1.el6.rfx.x86_64

It seems like I'm stuck in a loop where I can't install RRDtool since it requires something that requires the RRDtool.

Is there a way to install RRDtool 1.4.7 on CentOS 6?

Thanks

  • Isn't there a proper repository available where you downloaded these files? If yes, activate it and just use yum install rrdtool. Otherwise, try to install all packages at the same time. – Sven Dec 26 '16 at 18:02
  • How can I install the packages at the same time? – Tzach Solomon Dec 26 '16 at 18:03
  • yum install <package1> <package2>.... These packages seem to come from the Repoforge extras repo. Use it. – Sven Dec 26 '16 at 18:06
  • Cool, I'll try that. Thanks – Tzach Solomon Dec 26 '16 at 18:08
  • 1
    This is not a circular dependency. rrdtool does not require perl-rrdtool. It does require several other things which you haven't attempted to install. Again, use repositories in the manner in which they were intended, and you will not run into this sort of problem. – Michael Hampton Dec 26 '16 at 19:21

Downloaded https://pkgs.org/centos-6/repoforge-x86_64/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm.html and installed it.

I was able to install RRD tools by using the command yum -y --enablerepo='rpmforge*' install rrdtool-1.4.7

As the first failed dependency was: libdbi.so.0()(64bit), installing or updating libdbi would have been my first suggestion.

wget http://ftp.tu-chemnitz.de/pub/linux/dag/redhat/el6/en/x86_64/rpmforge/RPMS/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm

yum install rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm

yum -y --enablerepo=rpmforge-extras install rrdtool-1.4.7

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.