Right now I have no ahost records set in Godaddy. I read something that said I should set it to, but I think that's for the case of domain name forwarding, NOT mapping, and that's not what I want. I already added my domain name to GAE and confirmed my ownership of the domain name. I also already added www to GAE and added a cname record of www pointing to ghs.google.com.

Then I tried access www.mydomain.com but it keeps forwarding to myappname.appspot.com.

Does anyone have any suggestions about what to do other than wait 48 hours? Should I have an ahost record set? If so what should I set it to?

PS: I read over this Q&A, https://stackoverflow.com/questions/817809/how-to-use-google-app-engine-with-my-own-domain-not-subdomain.

  • this article sam.curren.ws/index.cfm/2008/4/17/… says that i SHOULD have an a host record that points to google's ip address, and that mydomainname.com should be set to forward to www.mydomainname.com but if i set my a host record to point to googles ip address www.mydomainname.com shows google's main search page. again not what i want – saliem Nov 5 '09 at 23:49
  • okay so i tried a different subdomain other than www. i tried calendar.myappname.com . that works. www.myappname.com still doesn't work. makes me wonder if this is a built in restriction or something. ive read in so many different places that this works. even the google docs hint that www works. – saliem Nov 6 '09 at 1:29

You should not set A records to static IPs for App Engine. Set a CNAME for the 'www' subdomain to ghs.google.com, as you say you have, ensure everything is configured correctly in Google Apps, and give it 24 hours or so to make sure everything's propagated. If you want the 'naked' domain to redirect to the www domain, use Godaddy's redirection features to achieve this.

| improve this answer | |
  • 3
    waiting 24 hours did the trick. it works now. thanks! – saliem Nov 6 '09 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy