0

I've got a working Azure SQL instance running, and I'm trying to connect using FreeTDS over command line with my config as:

[azure]
    host = ********.database.windows.net
    port = 1433
    tds version = 7.2
    database = ********

Using 7.2 as that's the only version that seems to allow me to connect; anything else prints there was an issue connecting to the server. Once connected, trying to run a query like:

1> SELECT * FROM CourseSchema.Members
2> GO

Results in:

Msg 208 (severity 16, state 1) from ******** Line 1:
    "Invalid object name 'CourseSchema.Members'."

I've noticed that the object name seems to be treating the schema and table name as the same object, with an empty block after the following dot, and am not sure if this is perhaps something to do with the issue.

I've tried multiple configurations trying to sort this out, to no avail - any ideas?

  • have you tried using sql server tools for linux along with microsoft ODBC driver? These are the future anyway, give it a shot. – RK Kuppala Dec 28 '16 at 16:48
  • Unfortunately using a legacy project that requires the use of php-mssql. Turns out it just flat out refused to work with an Azure instance; had to spin up a VM and install SQL Server manually. – Tom Wilson Dec 31 '16 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.