1

I have upgraded apache2 from 2.2.x to 2.4.23 during a failover migration.

When I tried to start my server with my previous configuration I couldn't get it to work.

My default host contains Proxy directives that lead to applications installed on the production server on different ports. So the Apache server basically offers a gateway to several applications each one installed on its own (Tomcat) runtime.

Within the default-server.conf I had

ProxyPass        "/jira" "http://localhost:9090/jira" connectiontimeout=5 timeout=30
ProxyPassReverse "/jira" "http://localhost:9090/jira"


ProxyPreserveHost on
ProxyPass        /artifactory http://localhost:8081/artifactory
ProxyPassReverse /artifactory http://localhost:8081/artifactory

Apache will fail starting at the very first of these lines

Starting httpd (prefork) AH00526: Syntax error on line 202 of /etc/apache2/vhosts.d/default.include:
Invalid command 'ProxyPass', perhaps misspelled or defined by a module not included in the server configuration

The command line was:
/usr/sbin/httpd-prefork -f /etc/apache2/httpd.conf

But mod proxy is enabled

From /etc/sysconfig/apache2:

APACHE_MODULES="actions alias auth_basic authn_file authz_host authz_groupfile authz_user authn_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir php5 reqtimeout  mod_dav mod_dav_fs mod_proxy authz_core"

Also, running apache2ctl -M to show modules returns this interesting gem

# apache2ctl -M
AH00526: Syntax error on line 202 of /etc/apache2/vhosts.d/default.include:
Invalid ProxyPass|ProxyPassMatch parameter. Parameter must be in the form 'key=value'.

How can I make my reverse proxy work again? OS is SLES 11 SP4

-1

You need to enable mod_proxy_http; please check https://httpd.apache.org/docs/current/mod/mod_proxy.html#proxyrequests .

1
  • It would appear mod_proxy is actually enabled. – user2066657 Oct 20 '17 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.