0

Bind 9 , CentoOS 7

Looking for a solution to force bind on slave dns server (cache only) to update zone records
or flush some how the dns cache to get new

Tried to restart bind on both servers tried to increase serial on master

nothing seems to be working

any trick ?

  • 1
    Authoritative servers (i.e. slaves) don't "cache". If increasing the serial number isn't helping, you will need to provide more information. Are there any messages in your logs? Did you test to make sure that these servers can communicate with each other on port 53? (TCP and UDP) – Andrew B Dec 29 '16 at 8:14
  • they do communicate, ones a while, updates as per settings, the problem is I can not find a solution to do it per my request if I need it. And what do you mean they do not catching ? The catch only slave servers are not caching data from master DNS ? – user387694 Dec 30 '16 at 10:29
0

If you update the serial on the master, with a default configuration, the slave should be notified and catch the change. If not, have a look at also-notify configuration option of bind, but first make sure that DNS packets flow between the two (for notifies, AXFR, IXFR, etc.).

You can use rndc on the slave (or through the network with the usual security caveats) to force the slave to reload the zone. But it will probably not work if the serial is not correctly increased.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy