0

In the FileMaker Server browser admin console, both Web Server and Web Publishing Engine are active (green check). When I go to the Test page (http://localhost:16001/test/) and click Test PHP Custom Web Publishing I get Error 22: Unknown Error. When I try to connect to a database using my own PHP code, I get Communication Error: (22) The requested URL returned error: 404 Not Found - This can be due to an invalid username or password, or if the FMPHP privilege is not enabled for that user. Clearly, neither of these messages give good insight into where the problem is. In the admin console, all of the relevant databases (both the test database and the active database for my own PHP code) show that they have fmwebdirect and PHP enabled. Where should I be looking to find the cause of this problem?

Details:
FileMaker Server 14.0.4.414
Mac OS X El Capitan (10.11.1)

0

Check out these steps that may help you. https://community.filemaker.com/message/507752#507752

Steps are outlined here as per request.

  1. Fix this script on the client machine running the PHP API: ../FMP12/FileMaker/Implementation/FileMakerImpl.php

change: if (stristr("50", curl_error($Vd88fc6ed))) {

to:if (stristr(curl_error($Vd88fc6ed),"50")) {

  1. Edit this file: /Library/FileMaker Server/Web Publishing/publishing-engine/php/yosemite/lib/php.ini

( My comment: If you run Mac OS X Yosemite, otherwise find the folder matching your OS)

change: default_socket_timeout = 60 to: default_socket_timeout = 120

change: max_execution_time = 30 to: max_execution_time = 90

change: max_input_time = 60 to: max_input_time = 120

change: session.cache_expire = 30 to: session.cache_expire = 180

  1. Edit this file: /Library/FileMaker Server/Admin/admin-helper/WEB-INF/conf/mod_proxy.conf actually no edits but keep this file in mind for future.

  2. Edit this file: /Library/FileMaker Server/HTTPServer/conf/extra/httpd-proxy.conf add this statement after the closing tag </Proxy>:

ProxyTimeout 180

  1. Edit this file: /Library/FileMaker Server/HTTPServer/conf/httpd.conf

Add these statements after all the LoadModule statements:

 Timeout 180 KeepAlive On MaxKeepAliveRequests 200 KeepAliveTimeout 30

  1. Restart the apache server

cd "/Library/FileMaker Server/HTTPServer/bin"

sudo ./httpdctl graceful

  • Thanks for this link. I tried all of these fixes, still getting the same error. I get the error nearly instantly, less than 1 second load time, so I don't think this could be related to a timeout issue. – bwalsh Dec 30 '16 at 13:16
  • Hard to say what it can be then, have you tried uninstalling and reinstalling? Otherwise, I suggest you take the issue to fmforums.com or the official FileMaker forum from the above link. Lots of experts there on FM server. – AndreasT Dec 30 '16 at 13:20
  • Please include the key points from the linked page in the text of your answer in case the link ever dies. – D34DM347 Dec 30 '16 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.