1

I'm using Google App Engine with custom domain. (Flexible type with nodejs)

When I completed settings it with https://cloud.google.com/appengine/docs/python/console/using-custom-domains-and-ssl?hl=en , I could visit my site with custom domain "mydomain.com"

It's good. However, the problem is that URL address in my browser shows redirected URLs such as : "myGAEdomain.appspot-preview.com"

How can I get the address "mydoamin.com" in the browser URL address bar when I visited my GAE site ? Or which part should I have to check to resolve this?

1

You’re right, the App Engine Flexible Environment is currently in Beta as stated on the official page and its implementation may change, possibly in backward-incompatible ways.

Now, in order to use Custom Domains with a Flexible Environment GAE instance, you first need to whitelist them prior adding them for your application as mentioned in this Before you Begin section. Listed in the third point, it is possible to whitelist the domains by filling out this Google contact form.

Note that prior using any custom domains, all GAE instance's traffic is served from the appspot-preview.com domain as described in the Domain Update section. Therefore, it is possible that you were initialy able to map yourdomain.com to YourProjectID.appspot-preview.com and so, presumably having your ProjectID the same as yourdomain name would explain the behavior you noticed.

0

OK, this is the report about what I did and how it's going.

I mailed Google with this issue and they resolved this problem in 2 days. I'm not sure if this should be resolved by Google only, however, the menu was slightly changed after my request. I cannot see detailed domain setting any more. I think Google App Engine Flex is on Beta service now and the domain thing is still on development.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.