1

Using Windows 7 Pro, Mysql server 5.7 installed on local pc.

It was working till the pc moved to another private network. When I open Mysql Workbench and click the only connection I have, it doesn't ask for any password, when it should, it did before. When I disable Windows Firewall all its fine, I tried to add Indbound and Outbound exeptions to 3306 port TCP, in Private and Domain mode to the Windows Firewall, but when I close the windows the rules disappear, the name is codified, and other rules just doesn't add.

mysqld.exe is the only service of mysqlserver present in inbound and outbound rules.

Edit:

Modifying the connection in the workbench from 'localhost' to 'serverIP' (wich is the same host) works. But doesn't work for other programs which need connection too. Any suggestion?

1

Solved, it was another firewall that was giving issues with Windows services and other stuff. I had to add rules in Control Panel/Windows Firewall/Advanced settings/Inbound rules and add new rule for connections over port 3306

| improve this answer | |
0

Windows 7 and Windows 10: Allow access through windows firewall for program C:\Program Files (x86)\Ampps\mysql\bin\mysql and ...\mysqld Firewall advanced settings and make a new inbound rule for tcp port 3306. Install the appropriate C++ for 2010, mine was (x86)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.