0

Am I doing anything wrong when installing php with cassandra extension on a CentosOS 7 server?

For dependencies I install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm and https://rpms.remirepo.net/enterprise/remi-release-7.rpm. Then I do:

yum install -y --enablerepo=epel,remi,remi-php70 \
php \
php-mbstring \
php-mysqlnd \
php-pecl-apcu \
php-pecl-cassandra

When the command finishes it always gives me:

Error: Package: php-pecl-cassandra-1.2.2-1.el7.remi.7.0.x86_64 (remi-php70)
           Requires: libuv.so.0.10()(64bit)

If I try to search for libuv, the result is as follow (no 0.10 version listed):

yum search --enablerepo=epel,remi,remi-php70 libuv --showduplicates
Loaded plugins: fastestmirror, ovl
Determining fastest mirrors
 * base: mirror.nbtelecom.com.br
 * epel: mirror.globo.com
 * extras: centos.xpg.com.br
 * remi: remi.xpg.com.br
 * remi-php70: remi.xpg.com.br
 * remi-safe: remi.xpg.com.br
 * updates: centosp4.centos.org
============================== N/S matched: libuv ==============================
1:libuv-devel-1.9.1-1.el7.x86_64 : Development libraries for libuv
1:libuv-1.9.1-1.el7.x86_64 : Platform layer for node.js
1:libuv-static-1.9.1-1.el7.x86_64 : Platform layer for node.js - static library
php-pecl-uv-0.1.0-1.el7.remi.7.0.x86_64 : Libuv wrapper
php-pecl-uv-0.1.1-1.el7.remi.7.0.x86_64 : Libuv wrapper
php70-php-pecl-uv-0.1.0-1.el7.remi.x86_64 : Libuv wrapper
php70-php-pecl-uv-0.1.0-1.el7.remi.x86_64 : Libuv wrapper
php70-php-pecl-uv-0.1.1-1.el7.remi.x86_64 : Libuv wrapper
php70-php-pecl-uv-0.1.1-1.el7.remi.x86_64 : Libuv wrapper
php71-php-pecl-uv-0.1.1-1.el7.remi.x86_64 : Libuv wrapper
php71-php-pecl-uv-0.1.1-1.el7.remi.x86_64 : Libuv wrapper
php71-php-pecl-uv-0.1.1-2.el7.remi.x86_64 : Libuv wrapper
php71-php-pecl-uv-0.1.1-2.el7.remi.x86_64 : Libuv wrapper

  Name and summary matches only, use "search all" for everything.
2

Indeed you found an issue (which should be better reported on github)

libuv have been recently updated (incompatible version) in EPEL.

The new build (1.2.2-4) available in the repository fixes this issue.

$ rpm -qp --requires php-pecl-cassandra-1.2.2-4.el7.remi.7.0.x86_64.rpm 
libuv.so.1()(64bit)

$ rpm -qp --provides libuv-1.9.1-1.el7.x86_64.rpm 
libuv.so.1()(64bit)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.