1

I am experiencing an odd issue with exchange 2010 and outlook 2010 when it comes to setting up out of office replies and wondering if you came across the issue before?

On outlook when clicking File > Automatic Replies, users get an error message " Your Automatic reply settings cannot be displayed because the server is currently unavailable. Try again later."

Now here is the weird thing: 1) You can set up out of office replies with no issues over outlook web access. 2) When you add the user on active directory as domain admin or exchange security groups that are members of an administrator e.g. Exchange Trusted Subsystem, log off and log back on, you can then setup automatic replies on outlook.

This is happening for all end users (over 40 end users / devices) domain and non-domain joined computers, inside and outside the local network.

Thank you and looking forward on your replies / solution.

migrated from superuser.com Jan 4 '17 at 14:40

This question came from our site for computer enthusiasts and power users.

0

One of the most likely reasons for this problem is that your autodiscover settings are misconfigured.

If this works for admin users and not for normal users, this might point to the autodiscover website permissions not being configured correctly - e.g. it has permissions set against it that it should not that limit it to admin access only. This could be NTFS permissions against the C:\Program Files\Microsoft\Exchange Server\ClientAccess\Autodiscover(or similar) folder. I think Authenticated Users needs to have full control of the autodiscover.xml file but I can't verify that offhand, sorry, or it could be IIS site permissions.

Without a 2010 deployment handy to test against, I would suggest testing autodiscover, which you can do in Outlook 2010 as follows, if I remember rightly:

  1. Start Outlook 2010 as you normally would.
  2. Outlook will place an icon in the System Tray on startup.
  3. Hold the key, right-click the Outlook System Tray icon, and choose “Test E-mail Autoconfiguration”.
  4. Enter your email address, password, and ONLY select Use Autodiscover. Then run the test!

Try this for an admin user where things work and a normal user where things do not work.

If this looks like the issue and you've looked at NTFS permissions, then check the IIS settings on the autodiscover site. They should be Autodiscover: Anonymous authentication, Basic authentication, Windows authentication - ideally these IIS sites should only be managed via Exchange/Exchange Powershell but if I'm right, its most likely this is no longer the case.

You might be able to restore the rights by editing them in IIS but at this point I'd strongly suggest re-creating the Autodiscover virtual directory via the Exchange Powershell Management Shell, using the guides here.

  • Hi Rob, thank you for your reply. At first i thought that was the issue and after recreating the exchange web services and autodiscover directories the issue still existed. Also the test through the outlook system Tray Icon Test Email AutoConfiguration autodiscover results succeeded but i still have the same issue which had left me puzzled. – AORUS Jan 3 '17 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.