-1

I've a freshly installed Centos 7 with just the basics and apache-php-mysql but I cannot find a way to run apache on port 80.

Since the machine is used just locally I've disabled selinux and firewall, when I try to run apache I get:

(13)Permission denied: AH00072: make_sock: could not bind to address 127.0.0.1:80 
no listening sockets available, shutting down 
AH00015: Unable to open logs

I've already checked on port 80 with netstat -tlnp but there is nothing running

1
  • 1
    is your loopback interface up? can you ping 127.0.0.1? – rAlen Jan 5 '17 at 17:07
2

This has nothing to do with SELinux (which you should not have disabled).

You cannot start Apache as a regular user and bind to port 80. You must start it as root, and you should use the included systemd unit to do so.

sudo systemctl start httpd
0

The first part of the message states that there is a Permission error. Make sure that the Apache has the correct filesystem access.

I also just found this which may help.

https://wiki.apache.org/httpd/13PermissionDenied

2
  • The rest of the line indicates that the permission denied is the permission to create a listening socket. It's not a filesystem access error. – Jenny D Jan 10 '17 at 14:27
  • I did see that, it looks like I misread the error codes (oops!) – BanjoFox Jan 11 '17 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.