We have an issue with Windows Search since we moved the file server from 2008 R2 to 2012 R2. I do have Windows Search installed and the shares indexed (almost 1 million files and I have re-indexed the files).

From the mapped drives on workstations we are finding that it is not returning all results. For example I can search withdraw but it doesn't find the files withdraw v2 or withdraw v3.

What I have found out is these files are about 3 to 5 levels deep from the root of the mapped drive. If I go from the root to one level up and search then it finds the file, however searching from the root it doesn't find it.

This is creating a big problem. How can I fix this behavior so that complete search results are returned from the parent folder?

  • Does the same behavior occur for searched performed directly on the server? What OS are the workstations running? – I say Reinstate Monica Jan 7 '17 at 4:19
  • The server is 2012 r2 and the client is Windows 7 pro. When I search on the server it shows up instantly (indexing). When I search from the client it takes about 1 minute and it does show about 111 results but it is missing! Just recently I have tried a new workstation joined to the domain and a new user and I get the same results. I'm running out of ideas and may need to open a case with Microsoft.. argh – Jacob Jan 11 '17 at 3:16

I ended up rebuilding the index on the server, making sure it was using DFS, and it started working again. I already rebuilt the index on the server before so i'm not sure what this worked this time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.