1

Some time ago my ZFS pool became unavailable and I tried a few things to get access to the files on it to remove what I could. I gave up as I have limited knowledge of ZFS. However, I am in the process of setting up a new server and I would really like to at a minimum recover what is on the apparent two good drives before setting up a new system.

When I do a zpool list I get some rpool listed, however my large tank pool RaidVol is not listed. But when I use a zpool import I get the following:

pool: RaidVol
id: 16881038089561338671
state: UNAVAIL
status: One or more devices are missing from the system.
action: The pool cannot be imported. Attach the missing
    devices and try again.
see: http://illumos.org/msg/ZFS-8000-3C
config:

    RaidVol                  UNAVAIL  insufficient replicas
      raidz1-0               UNAVAIL  insufficient replicas
        c6t0d0               ONLINE
        c6t1d0               ONLINE
        4996290435585416026  UNAVAIL  cannot open
        c6t3d0               UNAVAIL  cannot open

Is anyone able to assist with either getting the files off or getting this pool back up. I have some smaller 1TB drives I could replace the last two drives with if possible, but from memory, only the third drive is actually buggered...

Cheers, Jeff

UPDATE:

pool: RaidVol
id: 16881038089561338671 
state: DEGRADED 
status: One or more devices are missing from the system. 
action: The pool can be imported despite missing or 
    damaged devices. The fault tolerance of the pool may be 
    compromised if imported. 
see: illumos.org/msg/ZFS-8000-2Q 
config: 

    RaidVol                  DEGRADED 
      raidz1-0               DEGRADED 
        c6t0d0               ONLINE 
        c6t1d0               ONLINE 
        4996290435585416026  UNAVAIL  cannot open 
        c6t3d0               ONLINE

Not sure what to do from here, even if the only thing I can do is get access to get the files off, I would be forever grateful...

  • You're missing two devices. What happened to them? – Michael Hampton Jan 7 '17 at 3:17
  • Hi Michael, I'm not, which has led me to think that maybe something has happened to the SATA chassis... I'm investigating that now. – Jeff Lester Jan 7 '17 at 3:27
  • Okay, I now have all but one device available. One was a bad disk, which I have removed. However, it was a 2TB disk and I only have a 1TB disk to replace it with, will this be a problem? – Jeff Lester Jan 7 '17 at 3:41
  • pool: RaidVolid: 16881038089561338671 state: DEGRADED status: One or more devices are missing from the system. action: The pool can be imported despite missing or damaged devices. The fault tolerance of the pool may be compromised if imported. see: illumos.org/msg/ZFS-8000-2Q config: RaidVol DEGRADED raidz1-0 DEGRADED c6t0d0 ONLINE c6t1d0 ONLINE 4996290435585416026 UNAVAIL cannot open c6t3d0 ONLINE – Jeff Lester Jan 7 '17 at 3:42
  • Are there no ZFS experts around who might have an idea of what I'm doing wrong? – Jeff Lester Jan 9 '17 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.