2

It looks fine from SSH:

[root@FREENAS1] ~# ping SERVER1
PING SERVER1.local.domain.com (192.168.2.2): 56 data bytes
64 bytes from 192.168.2.2: icmp_seq=0 ttl=128 time=0.265 ms
64 bytes from 192.168.2.2: icmp_seq=1 ttl=128 time=0.365 ms
^C
--- SERVER1.local.domain.com ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.265/0.315/0.365/0.050 ms
[root@FREENAS1] ~# sqlite3 /data/freenas-v1.db "update directoryservice_activedirectory set ad_enable=1;"
[root@FREENAS1] ~# echo $?
0
[root@FREENAS1] ~# service ix-kerberos start
[root@FREENAS1] ~# service ix-nsswitch start
[root@FREENAS1] ~# service ix-kinit start
[root@FREENAS1] ~# service ix-kinit status
[root@FREENAS1] ~# echo $?
0
[root@FREENAS1] ~# klist
Credentials cache: FILE:/tmp/krb5cc_0
        Principal: administrator@local.domain.com

  Issued                Expires               Principal
Jan  8 15:02:48 2017  Jan  9 01:02:48 2017  krbtgt/local.domain.com@local.domain.com
[root@FREENAS1] ~# python /usr/local/www/freenasUI/middleware/notifier.py start cifs
True
[root@FREENAS1] ~# service ix-activedirectory start
Using short domain name -- INTERNAL
Joined 'FREENAS1' to dns domain 'local.domain.com'
[root@FREENAS1] ~# service ix-activedirectory status
[root@FREENAS1] ~# echo $?
0
[root@FREENAS1] ~# python /usr/local/www/freenasUI/middleware/notifier.py restart cifs
True
[root@FREENAS1] ~# service ix-pam start
[root@FREENAS1] ~# service ix-cache start &
[1] 75602
[root@FREENAS1] ~#

However, when I try and find the users/Windows Auth Options or CIFS under the sharing tab like I see in the guides, I am not seeing anything.

Am I missing something about how to add Domain users to SMB/NFS/CIFS shares?

Version:

FreeBSD 10.3-STABLE (FreeNAS.amd64) #0 r295946+47645f1(9.10.2-STABLE): Mon Dec 1                                             9 08:30:01 UTC 2016

EDIT: I also turned on the Active Directory service that seems to also have no effect.

1

In the GUI go to Directory -> Active Directory. Join the Domain. This then builds a user cache. You can then set the owner for individual mountpoints to Domain Users/Groups under storage->permissions. Set the permission type to 'Windows'. You can now connect to FreeNAS with the Owner. Then you can set ACL through windows explorer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.