4

To login with ssh I do this:

ssh -i ~/.ssh/kp1.pem ubuntu@ec2-xxxx.com

I tried all this with mosh:

mosh --ssh='ssh -i ~/.ssh/kp1.pem ubuntu@ec2-xxxx.com'

mosh -i ~/.ssh/kp1.pem ubuntu@ec2-xxxx.com

But I get the error:

/usr/bin/mosh: could not get canonical name for /home/$USER/.ssh/kp1.pem: Name or service not known
ssh_exchange_identification: Connection closed by remote host
/usr/bin/mosh: Did not find remote IP address (is SSH ProxyCommand disabled?).
7

I ended up needing to run the command like this:

mosh --ssh="ssh -i ~/.ssh/kp1.pem" ubuntu@ec2-xxxx.com

This works, but I also needed to add a rule for port 60001 for mosh to run on in the EC2 management console under security groups.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.