0

This is my environment:

  • DC1 (PDC) - IP: 192.168.1.11/24
  • DC2 - IP 192.168.1.12/24
  • DC3 - IP 192.168.2.10/24

Subnet 192.168.1.x/24 is connected to subnet 192.168.2.x/24, and domain controllers are correctly replicating informations.

I have also a 3rd subnet 192.168.3.x/24, connected to 192.168.2.x but not to 192.168.1.x.

Issue:

  • If I join to domain a client that is on subnet 192.168.1.x or 192.168.2.x everything works fine
  • If I try to join to domain a client that is on subnet 192.168.3.x, it fails, and I receive this error: "An Active Directory Domain Controller for the domain mydomain.local could not be contacted

Moreover if I run "nlstest /dsgetdc:mydomain.local" on the same client, I receive: "Getting DC name failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN"

Can you suggest me a possible troubleshooting? Please tell me if I didn't explain clearly.

Thank you in advance,

Federico

  • 3
    What DNS server is the client on 192.168.3.x configured to use? – Greg Askew Jan 10 '17 at 15:28
  • Agreed with @GregAskew. It's always DNS. Always. :) – EEAA Jan 10 '17 at 16:24
0

Can you check the DNS Settings of the client on subnet 192.168.3.0/24 and compare with the settings of a client on subnet 192.168.2.0 or 192.168.1.0? are they the same? if not try adjusting the DNS settings of the client on subnet 192.168.3.0/24 to match that of the client on subnet 192.168.1.0 or 192.168.2.0.

If the client is using a DNS server that doesn't host the DNS zone for your domain it would explain the issue.

Also has subnet 192.168.3.0/24 been added to AD Sites and services?

| improve this answer | |
0

Thanks everybody for anwers, DNS were correctly configured.

I ran "netdiag" and "net share" on domain controller and found that NETLOGON and SYSVOL share weren't available.

I followed this article (http://www.careexchange.in/sysvol-and-netlogon-share-is-missing-in-newly-built-domain-controllers-2008r22012r2/) to recreate them, and now clients from all the subnets can join to the domain.

Thank you again, Federico

| improve this answer | |
0

I just want to add that I had this same error but the root cause was different and maybe this will help someone else out.

I had a more simple network 10.15.10.x with a single DC. There was a Sonicwall acting as DHCP. The dns addresses it handed out were in the order 75.75.75.75, 75.75.76.76, 10.15.10.5.

I simply had to make sure the 10.15.10.5 was listed first and then renew the ip on my client pc and it was able to join the domain and see the DC just fine.

| improve this answer | |
  • It probably should not be handing out the Comcast DNS servers at all. – Michael Hampton Aug 29 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.