0

I am trying to bring a 3 layer (frontend,server and db) initial instalation of zabbix 3.x but I cannot pass the login page.

Here are my docker lines:

http://pastebin.com/79g1Mucb

And here are my docker logs:

  • DB:

"The files belonging to this database system will be owned by user "postgres". This user must also own the server process.

The database cluster will be initialized with locale "en_US.utf8". The default database encoding has accordingly been set to "UTF8". The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory /var/lib/postgresql/data ... ok creating subdirectories ... ok selecting default max_connections ... 100 selecting default shared_buffers ... 128MB selecting dynamic shared memory implementation ... posix creating configuration files ... ok running bootstrap script ... ok performing post-bootstrap initialization ... ok syncing data to disk ... ok

WARNING: enabling "trust" authentication for local connections You can change this by editing pg_hba.conf or using the option -A, or --auth-local and --auth-host, the next time you run initdb.

Success. You can now start the database server using:

pg_ctl -D /var/lib/postgresql/data -l logfile start

waiting for server to start....LOG: database system was shut down at 2017-01-11 09:25:23 BRST LOG: MultiXact member wraparound protections are now enabled LOG: database system is ready to accept connections LOG: autovacuum launcher started done server started CREATE DATABASE

CREATE ROLE

/docker-entrypoint.sh: ignoring /docker-entrypoint-initdb.d/*

LOG: received fast shutdown request LOG: aborting any active transactions waiting for server to shut down....LOG: autovacuum launcher shutting down LOG: shutting down LOG: database system is shut down done server stopped

PostgreSQL init process complete; ready for start up.

LOG: database system was shut down at 2017-01-11 09:25:27 BRST LOG: MultiXact member wraparound protections are now enabled LOG: database system is ready to accept connections LOG: autovacuum launcher started LOG: received smart shutdown request LOG: autovacuum launcher shutting down LOG: shutting down LOG: database system is shut down LOG: database system was shut down at 2017-01-11 09:26:52 BRST LOG: MultiXact member wraparound protections are now enabled LOG: database system is ready to accept connections LOG: autovacuum launcher started"

  • SERVER:

"** Preparing the system ** Preparing Zabbix server


  • DB_SERVER_HOST: zabbix-db
  • DB_SERVER_PORT: 5432
  • DB_SERVER_DBNAME: zabbix
  • DB_SERVER_ZBX_USER: zabbix
  • DB_SERVER_ZBX_PASS: a4d29cf3faab2ec897f2d11e599fe234

** Database 'zabbix' already exists. Please be careful with database owner! ** Creating 'zabbix' schema in PostgreSQL ** Fill the schema with initial data ** Preparing Zabbix server configuration file ** Updating '/etc/zabbix/zabbix_server.conf' parameter "ListenPort": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SourceIP": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "LogType": 'console'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "LogFile": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "LogFileSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "PidFile": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "DebugLevel": '3'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "DBHost": 'zabbix-db'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "DBName": 'zabbix'... updated ** Updating '/etc/zabbix/zabbix_server.conf' parameter "DBUser": 'zabbix'... updated ** Updating '/etc/zabbix/zabbix_server.conf' parameter "DBPort": '5432'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "DBPassword": 'a4d29cf3faab2ec897f2d11e599fe234'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartPollers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartIPMIPollers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartPollersUnreachable": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartTrappers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartPingers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartDiscoverers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartHTTPPollers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartTimers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartEscalators": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "JavaGateway": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "JavaGatewayPort": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartJavaPollers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartVMwareCollectors": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "VMwareFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "VMwarePerfFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "VMwareCacheSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "VMwareTimeout": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SNMPTrapperFile": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartSNMPTrapper": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "HousekeepingFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "MaxHousekeeperDelete": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SenderFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "CacheSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "CacheUpdateFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartDBSyncers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "HistoryCacheSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "HistoryIndexCacheSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "TrendCacheSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "ValueCacheSize": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "Timeout": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "TrapperTimeout": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "UnreachablePeriod": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "UnavailableDelay": ''... removed :Unlinking stale socket /var/run/supervisor.sock ** Updating '/etc/zabbix/zabbix_server.conf' parameter "UnreachableDelay": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "AlertScriptsPath": '/usr/lib/zabbix/alertscripts'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "ExternalScripts": '/usr/lib/zabbix/externalscripts'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "FpingLocation": '/usr/sbin/fping'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "Fping6Location": '/usr/sbin/fping6'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SSHKeyLocation": '/var/lib/zabbix/ssh_keys'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "LogSlowQueries": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "StartProxyPollers": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "ProxyConfigFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "ProxyDataFrequency": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SSLCertLocation": '/var/lib/zabbix/ssl/certs/'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SSLKeyLocation": '/var/lib/zabbix/ssl/keys/'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "SSLCALocation": '/var/lib/zabbix/ssl/ssl_ca/'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "LoadModulePath": '/var/lib/zabbix/modules/'... added ** Updating '/etc/zabbix/zabbix_server.conf' parameter "TLSCAFile": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "TLSCRLFile": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "TLSCertFile": ''... removed ** Updating '/etc/zabbix/zabbix_server.conf' parameter "TLSKeyFile": ''... removed ** Cleaning the system"

  • FRONTEND:

"** Deploying Zabbix frontend (nginx) with postgresql database ** Preparing the system ** Preparing Zabbix web-interface


  • DB_SERVER_HOST: zabbix-db
  • DB_SERVER_PORT: 5432
  • DB_SERVER_DBNAME: zabbix
  • DB_SERVER_ZBX_USER: zabbix
  • DB_SERVER_ZBX_PASS: a4d29cf3faab2ec897f2d11e599fe234

** Disable default vhosts ** Adding Zabbix virtual host (HTTP) :2017/01/11 11:28:53 [alert] 33#0: setrlimit(RLIMIT_NOFILE, 256000) failed (1: Operation not permitted) 2017/01/11 11:28:53 [alert] 34#0: setrlimit(RLIMIT_NOFILE, 256000) failed (1: Operation not permitted) 2017/01/11 11:28:53 [alert] 36#0: setrlimit(RLIMIT_NOFILE, 256000) failed (1: Operation not permitted) 2017/01/11 11:28:53 [alert] 37#0: setrlimit(RLIMIT_NOFILE, 256000) failed (1: Operation not permitted) 2017/01/11 11:28:53 [alert] 35#0: setrlimit(RLIMIT_NOFILE, 256000) failed (1: Operation not permitted) [11-Jan-2017 11:28:53] WARNING: Nothing matches the include pattern '/etc/php5/fpm.d/*.conf' from /etc/php5/php-fpm.conf at line 15. **** Impossible to enable SSL support for Nginx. Certificates are missed. ** Preparing Zabbix frontend configuration file ** Updating '/etc/php5/conf.d/99-zabbix.ini' parameter "max_execution_time": '300'... updated ** Updating '/etc/php5/conf.d/99-zabbix.ini' parameter "memory_limit": '512M'... updated ** Updating '/etc/php5/conf.d/99-zabbix.ini' parameter "post_max_size": '64MB'... updated ** Updating '/etc/php5/conf.d/99-zabbix.ini' parameter "upload_max_filesize": '2M'... updated ** Updating '/etc/php5/conf.d/99-zabbix.ini' parameter "max_input_time": '300'... updated ** Updating '/etc/php5/conf.d/99-zabbix.ini' parameter "date.timezone": 'UTC'... updated ** Cleaning the system

#

** Executing supervisord 2017-01-11 11:28:51,808 CRIT Set uid to user 0 2017-01-11 11:28:51,808 CRIT Set uid to user 0 2017-01-11 11:28:51,808 WARN Included extra file "/etc/supervisor/conf.d/supervisord_zabbix.conf" during parsing 2017-01-11 11:28:51,808 WARN Included extra file "/etc/supervisor/conf.d/supervisord_zabbix.conf" during parsing 2017-01-11 11:28:51,827 INFO RPC interface 'supervisor' initialized 2017-01-11 11:28:51,827 INFO RPC interface 'supervisor' initialized 2017-01-11 11:28:51,827 INFO supervisord started with pid 1 2017-01-11 11:28:51,827 INFO supervisord started with pid 1 2017-01-11 11:28:52,836 INFO spawned: 'nginx' with pid 31 2017-01-11 11:28:52,836 INFO spawned: 'nginx' with pid 31 2017-01-11 11:28:52,842 INFO spawned: 'php-fpm' with pid 32 2017-01-11 11:28:52,842 INFO spawned: 'php-fpm' with pid 32 2017-01-11 11:28:54,338 INFO success: nginx entered RUNNING state, process has stayed up for > than 1 seconds (startsecs) 2017-01-11 11:28:54,338 INFO success: nginx entered RUNNING state, process has stayed up for > than 1 seconds (startsecs) 2017-01-11 11:28:54,338 INFO success: php-fpm entered RUNNING state, process has stayed up for > than 1 seconds (startsecs) 2017-01-11 11:28:54,338 INFO success: php-fpm entered RUNNING state, process has stayed up for > than 1 seconds (startsecs) 10.0.2.2 - - [11/Jan/2017:11:30:12 +0000] "GET / HTTP/1.1" 200 1218 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0" "-" 10.0.2.2 - - [11/Jan/2017:11:30:12 +0000] "GET /styles/blue-theme.css HTTP/1.1" 200 17854 "http://127.0.0.1:8080/" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0" "-" ..."

Now when I try to login with the default credentials Admin/zabbix the login page keeps redirecting me to itself.

  • This looks like a SELINUX issue. Do you have it enabled? – dimir Feb 5 '17 at 10:02
  • @dirmir, I actually figured out the problem. The isse was the extra B in --env="ZBX_POSTMAXSIZE=64MB". It should be --env="ZBX_POSTMAXSIZE=64M" – bananabr Apr 30 '17 at 22:58
0

The isse was the extra B in --env="ZBX_POSTMAXSIZE=64MB". It should be --env="ZBX_POSTMAXSIZE=64M"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.