0

As the title suggests, I am having clear issues with mysql. (Am fairly new at this server management thing) Problems started after importing database files from another server. When logged in to phpmyadmin certain tables were claiming to not exist. So I deleted the tables, then went to import them using an export file and got the error "Table does not exist" when trying to create Tables. Figured it was odd, did some research and realized some permissions may have been set wrong. So i Chown-ed the databases and files to be owned by mysql and now nothing works.

Since then I've tried changing the permissions back to how they were before (as research on this new problem stated it could be a permission error), and even re-adding the dbs that were deleted that i had backed up (another source claimed the ibdata files may not have the right info). Nothing worked to help me solve my problem. Directly searching around for information on the errors in the log file didnt yeild many results or new information ether.

When I try to start mysql55-mysqld service in my CLI the only error I get is

MySQL Daemon failed to start.

mysql55-mysqld.log reports the following

170111 11:11:26 mysqld_safe Starting mysqld daemon with databases from              /opt/rh/mysql55/root/var/lib/mysql
170111 11:11:26 [Note] /opt/rh/mysql55/root/usr/libexec/mysqld (mysqld     5.5.52) starting as process 13140 ...
170111 11:11:26 [Note] Plugin 'FEDERATED' is disabled.
170111 11:11:26 InnoDB: The InnoDB memory heap is disabled
170111 11:11:26 InnoDB: Mutexes and rw_locks use GCC atomic builtins
170111 11:11:26 InnoDB: Compressed tables use zlib 1.2.3
170111 11:11:26 InnoDB: Using Linux native AIO
170111 11:11:26 InnoDB: Initializing buffer pool, size = 128.0M
170111 11:11:26 InnoDB: Completed initialization of buffer pool
170111 11:11:26 InnoDB: highest supported file format is Barracuda.
170111 11:11:26  InnoDB: Waiting for the background threads to start
170111 11:11:27 InnoDB: 5.5.52 started; log sequence number 1617709
170111 11:11:27 [Note] Server hostname (bind-address): '0.0.0.0'; port: 3306
170111 11:11:27 [Note]   - '0.0.0.0' resolves to '0.0.0.0';
170111 11:11:27 [Note] Server socket created on IP: '0.0.0.0'.
170111 11:11:28 [ERROR] Event Scheduler: Failed to open table mysql.event
170111 11:11:28 [ERROR] Event Scheduler: Error while loading from disk.
170111 11:11:28 [Note] Event Scheduler: Purging the queue. 0 events
170111 11:11:28 [ERROR] Aborting
170111 11:11:28  InnoDB: Starting shutdown...
170111 11:11:28  InnoDB: Shutdown completed; log sequence number 1617709
170111 11:11:28 [Note] /opt/rh/mysql55/root/usr/libexec/mysqld: Shutdown    complete
170111 11:11:28 mysqld_safe mysqld from pid file        /opt/rh/mysql55/root/var/run/mysqld/mysqld.pid ended

How can I fix this service to be working and usable again?

1

How can I fix this service to be working and usable again?

copy and paste this

[ERROR] Event Scheduler: Failed to open table mysql.event

into your favourite search engine. Do some reading (there appear to be plenty of articles to choose from) and try out the advice you find there.

If none of that helps, come back and update your question with what you learned, what you tried and what happened when you tried it.

Additional reading: Do you have a checklist that can help me ask a better question?

  • Have you taken your own advice? Im guessing not. So let me just show you how unhelpful that is, since you think im so ignorant as to not do a google search before asking a question. Result 1 : stackoverflow.com/questions/20570779/cant-start-mysqld-mysql - Vaguely resembles my problem but has no accepted answer and an unexplained Command line. Entering mysqld_safe --help doesnt even list the option let alone explain it. Result 2: forums.mysql.com/read.php?119,628996,628996 Displays no helpful solution or fix. Result 3 shows the post in result 2 and links to it. Not very helpful – Erudaki Jan 11 '17 at 17:24
  • I take my own advice all the time with the problems I have. – user9517 supports GoFundMonica Jan 11 '17 at 17:26
  • Thats great, but your answer is nether helpful, nor constructive, and makes way to many assumptions. – Erudaki Jan 11 '17 at 17:29
  • yeah your right, it assumes that like most people who just chuck mysql error logs at us you're a clueless idiot. – user9517 supports GoFundMonica Jan 11 '17 at 17:32
  • Right, I'm a clueless idiot for being new at this, and being unable to find a fix to an error I cant find much information on. I've stated some of the things I've tried, I've stated some of the research I've done, but hey, my fault for not having experience right? – Erudaki Jan 11 '17 at 17:38
0

Solved by yum removing mysql55 and deleting the databases yum had not removed. After reinstalling it, I was able to again start the service and after re-configuring it was able to log in and edit the databases and import the data I had backed up.

While this did fix the overall issue, it can be seen as more of a workaround as it did involve the loss of databases and may not be as viable for an existing system. If a better answer is posted I will change the accepted answer to match.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.