0

I have a .net application which calls a webservice deployed on my local windows server 2012 on IIS, and the sql server database resides on that server too. All employees connect to the same service and DB since we're all on the same domain, and I publish the app and webservice to the server through visual studio (2012).

Now I need to make employees access this application when they are outside the company's network, so I deployed the webservice on IIS on one of our remote windows 2012 servers, I created a public shared folder in my remote server and added to app webservice files to it and in visual studio I changed the publish method to web deploy and filled in the information as below:

Server: https://x.x.x.x/

Site Name: https://x.x.x.x/PublicFolder

Destication URL: https://x.x.x.x/PublicFolder/Application

When I click Validate Connection, it fails with the following message:

Could not connect to the remote computer ("x.x.x.x"). on the remote computer make sure that Web Deploy is installed and that the required process ("Web Management Service") is started. Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_DESTINATION_NOT_REACHABLE. Unable to connect to the remote server

Note that I tried to replace https with http and I got another error:

Could not connect to the remote computer ("x.x.x.x"). on the remote computer make sure that Web Deploy is installed and that the required process ("Web Management Service") is started. Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_USER_NOT_ADMIN. the remote server returned an error: (401)Unauthorized

I went to the previous link and I did what they suggested:

  • Create a separate user group MSDepSvcUsers on remote computer.
  • Create an local account A on both local & remote computer.
  • Add A to MSDepSvcUsers on remote computer.
  • Use account A to publish, this will allow you to publish without needing to use built-in admin account.

but the same error (NOT_ADMIN) remained

UPDATE: I found another possible solution:

Add/modify windows registery key “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\” and set it “1”.

After I added this registry key, the error changed to:

site 'http:' does not exist ... #ERROR_SITE_DOES_NOT_EXIST

So now if I put wrong credentials, I get the unauthorized error, if I use correct credentials I get side does not exist error.

What should I do?

0

It worked!!

I mean the connection, it's now validated, all I had to do is change site name from "http://x.x.x.x/PublicFolder" to "Default Web Site\SiteName" !!

This was really confusing, finally got it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.