0

I have a Dedicated Server and installed a VMWare-Esxi as main OS on it.

Then, I added 4 VMs on VMWare-Esxi :

VM1 - Windows Server 2008 - Local IP  192.168.100.10
VM2 - Windows Server 2008 - Local IP  192.168.100.11
VM3 - Windows Server 2008 - Local IP  192.168.100.12
VM4 - Mikrotik Router 6.6 - Public IP 149.252.96.29   // definitely it's not my real IP :)

What I want to do?

I want to implement port forwarding on Mikrotik Router to Local VMs like so :

149.252.96.29:1573 == forward to => 192.168.100.10:3389

149.252.96.29:1574 == forward to => 192.168.100.11:3389

149.252.96.29:1575 == forward to => 192.168.100.12:3389

The main question :

The main question is that I don't know how to add the VMs with local IP to the Mikrotik Router?

Any helps would be great appreciated.

1 Answer 1

2

You have to use Dnat action on nat tab of firewall like this:

/ip firewall nat add chain=dstnat  dst-address=149.252.96.29 protocol=tcp dst-port=1573 action=dst-nat to-addresses=192.168.100.10 to-ports=3389
/ip firewall nat add chain=dstnat  dst-address=149.252.96.29 protocol=tcp dst-port=1574 action=dst-nat to-addresses=192.168.100.11 to-ports=3389
/ip firewall nat add chain=dstnat  dst-address=149.252.96.29 protocol=tcp dst-port=1575 action=dst-nat to-addresses=192.168.100.12 to-ports=3389

Ofcourse you should have an IP address in range of 192.168.100.x on the mikrotik to be able to contact with servers.

-

And possibly if you have some Deny rules on mikrotik Firewall here is the code to allow these connection to pass through:

/ip firewall filter add place-before=0 chain=forward protocol=tcp dst-port=3389 action=accept
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .