3

Please note, this scenario is different from asimilar one: How do I disable TLS 1.0 without breaking RDP?

The linked question is about RDP and disabling TLS 1.0.

This question is about RemoteApp's and disabling TLS 1.0

I already have straight RDP over port 3389 working with TLS 1.2.

We have a 2012R2 Server hosting RemoteApp's.

We have the RD Gateway, RD Web Access, RD Connection Broker, RD Session Host roles installed on this server.

RemoteApp's are served through the RD Gateway over https. The only public port we have open is 443.

We have a public CA supplied wildcard SSL certificate installed in all of the RD Roles and IIS, so everything traces back to a trusted root cert.

The cert supports TLS 1.2, I see this in a webbrowser when I view the RDWeb website.

We are tying to disable TLS 1.0 on this server to tighten up the security. We are using IISCrypto 2.0 to disable TLS 1.0

When we disable TLS 1.0 two things are observed:

1.The RemoteApp's stop working. They cannot be launched from an end user machine.

2.Straight RDP connections work just fine.

When we re-enable TLS 1.0 the RemoteApp's work again.

SChannel logging confirms that RemoteApps are using TLS 1.2, so I would expect the RemoteApps to continue working when TLS 1.0 is disabled. However that is not what I am observing.

All client's are using fully updated/patched versions of Windows 8.1 and 10.

  • Ask Microsoft. Their applications are closed source so we cannot know why it behaves the way it does. – John Keates Jan 17 '17 at 19:26
5

After almost a year, I finally figured out a working solution for disabling TLS 1.0/1.1 without breaking RDP and Remote Desktop Services connectivity.

Run IISCrypto and disable TLS 1.0, TLS 1.1 and all bad ciphers.

On the Remote Desktop Services server running the gateway role, open the Local Security Policy and navigate to Security Options - System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing. Change the security setting to Enabled. Reboot for the changes to take effect.

Note that in some cases (especially if using self signed certificates on Server 2012 R2), the Security Policy option Network Security: LAN Manager authentication level may need to be set to Send NTLMv2 responses only.

Let me know if this works for you as well.

  • Have you used any RemoteApp's succesfully with this change? Or are you doing RDP with the RD Gateway (which is slightly different from RemoteApp's)? – Phil Sayers Feb 17 '17 at 22:41
  • I don't use RemoteApps in our environment, however, I had the same symptoms, i.e. I couldn't launch any published apps from the session host. Enabling FIPS resolved the issue. Let me know if this also resolves your RemoteApps issue. – cardiothoracics Feb 20 '17 at 19:07
  • Sorry, too many late nights. We do use RemoteApps, I was thinking of the RDWeb application feeds. And yes, the fix does work for RemoteApps that are published as part of the session host collection. – cardiothoracics Feb 24 '17 at 9:31
  • 1
    Confirmed, this works completely. We did run into issues with some Win 7 client users who needed TLS1.2 enabled on their machines. Combinations of [1] and [2] solved connection issues for the Win 7 machines. [1]blog.tmurphy.org/2015/07/… [2]support.microsoft.com/en-us/help/3140245/… – Phil Sayers Nov 29 '18 at 17:59
  • Confirmed that this works on Windows Server 2016 as well! Thanks! – Tim Friesen Apr 17 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.