2

Installed Redis 3.2.4 on OpenSuse 42.1 with package manager. The machine has 16GB of memory.

Did these steps to get running. (I would like to run as deamon, but havent changed the settings.)

  • cp default.conf.example default.conf
  • chown root.redis default.conf
  • systemctl enable redis@default
  • systemctl start redis@default
  • service redis start

Getting these errors:

54778:C 18 Jan 12:38:56.664 # systemd supervision requested, but    NOTIFY_SOCKET not found   

54778:M 18 Jan 12:38:56.665 # You requested    maxclients of 10000 requiring at least 10032 max file descriptors.     

54778:M 18 Jan 12:38:56.665 # Server can't set maximum open files to    10032 because of OS error: Operation not permitted.  

54778:M 18 Jan 12:38:56.665 # Current maximum open files is 4096. maxclients has    been reduced to 4064 to compensate for low ulimit. If you need higher    maxclients increase 'ulimit -n'.

54778:M 18 Jan 12:38:56.666 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.

54778:M 18 Jan 12:38:56.666 # Server started, Redis version 3.2.4

54778:M 18 Jan 12:38:56.666 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.

54778:M 18 Jan 12:38:56.666 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
1

must enter a row Type=forking in the section [Service] file redis.service

for Ubuntu type sudo nano /etc/systemd/system/redis.service

0

seems you need to tune your Linux Kernel. Take a look at the sysctl command, the sysctl.conf config file as well their respective man pages.

Yo need to increase the following kernel values: max file descriptors, max open files, maximum connections, enable overcommit memory and disable transparent huge pages. And restart after this

Seems your redis instance is running but with limited performance

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.