1

When creating my Elastic Beanstalk application, I selected the latest platform version of Amazon Linux running Ruby (Puma). But, it has an outdated version (compared to the current stable version) of Ruby & Bundler.

How can I create an EC2 instance with up-to-date software for running a Ruby app with Puma?

  • AWS packages are often a way behind current, they don't have mysql 5.7. You sometimes need to specify versions, so "yum install mysql56" instead of "you install mysql". You may have to install another repository outside AWS, though I don't know how to do that because I never tried. – Tim Jan 20 '17 at 18:14

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.