-1

I recently installed Apache 2.4 on a Windows Server 2012 machine.

Apache is listening on port 8079 (IIS is installed on that machine too)

It works fine if I access the web server with http://localhost:8079. However I can't access it on other computers on the network. I can't even access it with my own (server's) network ip address (192.168.9.3). Apache doesn't generate any error (403 or something). The connection just times out after a few seconds without talking to Apache.

IIS works fine on port 80, even on the LAN.

Port 8079 seems to be opened.

C:\ms4w\Apache\bin>netstat -a -n | find "8079"
  TCP    0.0.0.0:8079           0.0.0.0:0              LISTENING

I added a firewall rule to accept incoming connections on port 8079. According to the logs, it is accepting the connection.

Part of my httpd.conf file:

#Listen 12.34.56.78:80
Listen 8079

....

<Directory />
    AllowOverride none
    Require all denied
    Allow from all
</Directory>

....

<Directory "C:/ms4w/Apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride all
    Order deny,allow
    Allow from all
    Require all granted
</Directory>

Well now I am clueless... Any idea what's wrong?

0

Have you tried checking all these items?

  1. Check your web browser proxy settings ? If you use proxies, make sure to set your IP address added under "Do not use proxy settings for these addresses..." section in your web browser.

  2. Firewall ? Try Disabling them first.

  3. Software protection agents ? Such as Symantec protection agent ?

  4. Windows trusted app section, you might want to allow these apps to run on a certain network/ports.

Also always check your event logs for error messages. Also check your Apache error logs for hints.

The trick in general is list out the possibilities of software/feature in OS that could pose problems and then turn on/off them to validate it.

  • Thank you for your answer. There is nothing like a good night to think about a problem! I woke up this morning and I realized that the network uses DNS. I had to replace the ip by server1.something.local:8079/ – Gob Tron Jan 20 '17 at 12:59
  • Cool, glad that you solved the issue. Cheers! :) – Linux Cli Aik Jan 25 '17 at 6:50
0

I solved my problem.

I didn't realized that we were using DNS on the network. All I had to do (with the provided information) is to access the web server with

server1.something.local:8079/

instead of

192.168.16.3:8079/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.