0

System:
Ubuntu 16.04
Percona Server (using Galera cluster)
pure-ftpd-mysql from the Ubuntu repositories

The pureftpd database is replicated to all five servers in the cluster and I have verified the replication is working and the tables are identical.

Issue: I installed pure-ftpd-mysql on one of the five servers in our distributed cluster, and have it authenticating users correctly.

After installing pure-ftpd-mysql on each of the other servers I shut down pure-ftpd on each, deleted its folder in /etc, and used scp -r /etc/pure-ftpd server/etc/pureftpd to copy the working config files from the first server to the other four.

I can connect to the ftpd on each server, but I can only login on the first one. VerboseLog is set on each. Here is the syslog output from the workinh one and one of the non-workign ones:

Working: host hub

Jan 21 06:13:32 h0 pure-ftpd: (?@68.103.155.231) [INFO] New connection from 68.103.155.231
Jan 21 06:13:32 h0 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [auth] [TLS]
Jan 21 06:13:32 h0 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [auth] [SSL]
Jan 21 06:13:32 h0 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [user] [test]
Jan 21 06:13:32 h0 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [pass] [<*>]
Jan 21 06:13:32 h0 pure-ftpd: (?@68.103.155.231) [INFO] test is now logged in
Jan 21 06:13:32 h0 pure-ftpd: (test@68.103.155.231) [DEBUG] Command [opts] [UTF8 ON]
Jan 21 06:13:32 h0 pure-ftpd: (test@68.103.155.231) [DEBUG] Command [pwd] []

Non-working: host l1

Jan 21 06:15:28 l1 pure-ftpd: (?@68.103.155.231) [INFO] New connection from 68.103.155.231
Jan 21 06:15:28 l1 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [auth] [TLS]
Jan 21 06:15:28 l1 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [auth] [SSL]
Jan 21 06:15:28 l1 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [user] [test]
Jan 21 06:15:28 l1 pure-ftpd: (?@68.103.155.231) [DEBUG] Command [pass] [<*>]
Jan 21 06:15:28 l1 pure-ftpd: (?@68.103.155.231) [INFO] PAM_RHOST enabled. Getting the peer address
Jan 21 06:15:34 l1 pure-ftpd: (?@68.103.155.231) [WARNING] Authentication failed for user [test]
Jan 21 06:15:34 l1 pure-ftpd: (?@68.103.155.231) [INFO] Logout.

I have found limited information on the PAM_RHOST item and I kind of understand why it's happening, but I'm not sure how to get it shut off. Here is the current configuration:

AltLog
clf:/var/log/pure-ftpd/transfer.log

ChrootEveryone
yes

CreateHomeDir
yes

DontResolve
yes

FSCharset
UTF-8

MinUID
1000

MySQLConfigFile
/etc/pure-ftpd/db/mysql.conf

NoAnonymous
yes

PAMAuthentication
no

PureDB
/etc/pure-ftpd/pureftpd.pdb

TLSCipherSuite
ALL:!aNULL:!SSLv3

UnixAuthentication
no

VerboseLog
yes

At this point I'm at a loss as to why the configuration copied from the working server to the others is now allowing me to login. Looking for ideas and resources to find this answer...

0

I resolved this by removing pure-ftpd-mysql and reinstalling

apt remove pure-ftpd-mysql
apt autoremove
apt install pure-ftpd-mysql

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.