6

The nmbd logs of a linux samba4 domain member server are filled with lines like:

query_name_response: Multiple (2) responses received for a query on subnet 192.168.1.54 for name ADOMAIN<1d>.
This response was from IP 192.168.1.19, reporting an IP address of 192.168.1.19.

where:

  • 192.168.1.54 is the IP of the member server
  • 192.168.1.19 is the IP of the PDC
  • ADOMAIN is a SAMBA NT-style domain

Those lines appears every 5 minutes.

What is going on?

Random steps taken:

  • rm /var/cache/samba/browse.dat;
  • double check interfaces broadcast configuration (it is correct);
  • systemctl restart nmbd (a evergreen classic).
1
  • 1
    Did you ever get this sorted out? I am having the same issue on a couple FreeBSD VMs, but the answer below doesn't seem to apply to my network environment... May 6 '18 at 12:28
2

It could be because of a host in the same physical network which have two interfaces. The broadcast query coming in is replied to both of them by your nmbd. Please see this 17 years old answer at https://thr3ads.net/samba/2000/08/1675707-query_name_response-Multiple-responses-received

1

For me, the answer was to be found here: https://forums.freebsd.org/threads/samba-multiple-2-responses-two-freebsd-systems-on-my-network.65759/
And specifically the last sentence

If you are doing standalone, then you should have local master = no, domain master = no and preferred master = no. Disable all the wins stuff too. I think all you would need is workgroup = WORKGROUP

However, I don't use an NT domain to log on to. I actually use nothing more than a workgroup. the "prefered master = no" was the one I had to change. I had it set to 'yes' on 1 host. Changed to 'no' and restarted samba. Everything kept working after that and the messages stopped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.