0

We have a LAMP hosting server, Nginx as frontend for static files and reverse proxy for Apache. Apache + mod_php are serving php requests.

Apache

Server Version: Apache/2.4.10 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 PHP/5.6.29-0+deb8u1
Server MPM: prefork

PHP

PHP Version 5.6.29-0+deb8u1
OPCache enabled
max_execution_time 60

PHP scripts dies with error Maximum execution time of 60 seconds exceeded, but apache fork is still trying to serve this requests.

Strace apache child process is empty or shows futex system call

strace -p <PID>
Process <PID> attached
futex(0x7f16c503890, FUTEX_WAIT_PRIVATE, 2, NULL

server status page shows that such processes are in Sending Reply or Gracefully Finishing state with a very high numbers of seconds since beginning of most recent request, beyond of Apache Timeout value.

Apache and php both are standard debian jessie main packages. Debian version is 8.7

What can be wrong and how we can change apache settings to fix these hanged forks with such long php requests.

0

After few days of investigating, I found that issue is related with php-xdebug extension. Hanged forks has gone away after disabling xdebug from enabled php modules.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.