-2

I installed ESXi 6 as a main OS on my dedicated server and want to create some machines on it now, but in virtual machine creation wizard I got an error about "Warning - this host does not have suitable virtual machine networks,...".

So I checked my ESXi configuration/networking and check vSwitch0 and also check network adapters and see I have 2 vmnice (vmnic0 and vmnic1) but on of them is down and other one is used by vSwitch0...

How can I assign IP to my machine and solve this networking problem?

4

3 Answers 3

0

You probably have 2 network adapters on your server. The one that is used by vSwitch0 is the one connected. Don't worry about the one that is disconnected. If you take a look at the properties of your vSwicth 0, do you see the default VM Network? Take a look at this screenshot, do you see those 3 items? VM Network

2
  • you exactly get what is my problem! Great! I have 2 cards but one of them is down and in the properties of vSwitch0 I only have 2 of them, "vswitch" and "Management Network"...
    – David Vypr
    Jan 26, 2017 at 11:01
  • I can add "VM Network" but nothing changes and still I got an error machine creation wizards...imgur.com/a/v07Rr
    – David Vypr
    Jan 26, 2017 at 11:03
0

If the network label stays blank (if I recall this right it can happen also if you just rename a VLAN) the VM will not be able to boot.

The default network is VM Network, if you accidently removed it navigate to vSwitch0, click Properties, Add, Virtual Machine, enter Network Label (the name that will appear when you create a new virtual NIC for every server, i.e. VM Network) and VLAN ID if applicable (default 0), Next, Finish.

After you created the network you will be able to select it for your virtual network adapters (see Network Connection/Network Label where you will see the name that you just choose above). Check the VM that it has a network label assigned now.

The IP for a virtual machine itself does not get assigned by ESXi, you either have to configure it within the VM or use DHCP.

0

problem has been solved.

I should add "VM Network" to vSwitch0 and then problem solved and I can continue machine creation wizard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.