1

the server is running:

# cat /proc/version 
Linux version 2.6.32-431.el6.x86_64 (mockbuild@x86-023.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-4) (GCC) ) #1 SMP Sun Nov 10 22:19:54 EST 2013

and it seems that the libpcap-devel is not available, and i cannot find the package in any repository.

# yum search libpcap-devel
Loaded plugins: product-id, rhnplugin, search-disabled-repos, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Repository epel is listed more than once in the configuration
Repository epel-debuginfo is listed more than once in the configuration
Warning: No matches found for: libpcap-devel
No Matches found

The solution seems to be here: https://access.redhat.com/solutions/57913 but I do not have access ..

Could you please advise on how to solve this ?

2

Spelling out Michael's answer:

sudo yum-config-manager --enable rhel-6-server-optional-rpms
sudo yum install libpcap-devel
sudo yum-config-manager --disable rhel-6-server-optional-rpms

Or you can edit /etc/yum.repos.d/redhat.repo:

[rhel-6-server-optional-rpms]
name = Red Hat Enterprise Linux 6 Server - Optional (RPMs)
baseurl = https://cdn.redhat.com/content/dist/rhel/server/6/$releasever/$basearch/optional/os
enabled = 1
| improve this answer | |
1

libpcap-devel is in the RHEL optional channel, which you need to enable on your system.

And if you don't have access to RHEL documentation, you need to talk to whoever is in charge of that in your company to get your Red Hat account authorized for access.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.