I've got a Windows Server 2003 R2 Standard SP2 running. When I try to connect to this server using Remote Desktop I get the following error popup:

"The system cannot log you on due to the following error: The RPC server is unavailable."

In the event log of the server I get the following event: "Logon rejected for Domain\administrator. Unable to obtain Terminal Server User Configuration. Error: The RPC server is unavailable." (Source: Winlogon, Event ID: 1219)

What can I do to fix this problem? I got no clue which RPC server this refers to.


Create the following Registry key

hklm\system\Current Control Set\Control\Terminal Server
Name : IgnoreRegUserConfigErrors
Value : 1 (decimal)

Reboot the server, and try logging in via RDP.

  • Allright. I have VMs on VSphere, there are 2 (two) VSwitch: LAN and DMZ. Few days ago I got "Error: The RPC server is unavailable." while RDP using IP DMZ. Registry patch is working, now RDP using IP DMZ is fine. To whom had technical reference regarding this issue, please do not hesitate to share. Thank you. – Rhak Kahr Nov 26 '14 at 6:33

Are there any other errors in the event log, not related to terminal services? We need to determine if this is a problem with Terminal Services, or with the RPC service.

I have often seen this error 'TCP/IP NetBIOS Helper' service running? I've often seen the fact that this service was stopped cause this error.

The fact that you have an error accessing your group policy file may be related. One thing you can try is to check if "File and Print Sharing" is enabled on the adapter your trying to RDP too, if its not, turn it on and see if you can connect then.

  • The netbios helper service (and remote registry) are running. There are no other error messages at the same time. There are some messages because the server is unable to access the domain gpt.ini ("the format of the specified network name is invalid). – Sam Nov 9 '09 at 13:26
  • "File and Print Sharing" already is enabled on the (only) network connection of the windows server 2003 I'm trying to connect to. I opened another question for the GP problem. – Sam Nov 9 '09 at 14:02
  • Dang - I just installed all "optional updates" I could find, and now it works. Seems like someone already has fixed this? Thanks nonetheless! – Sam Nov 9 '09 at 14:44
  • No problem, glad that its working now! – Sam Cogan Nov 9 '09 at 14:52
  • 1
    Well, actually it is only working intermittendly. After some uptime connection fails, after a reboot it will work again. – Sam Aug 20 '10 at 11:55

I'm having the same problem. Do you find an answer for this?

I found this link http://support.microsoft.com/kb/555839 that says

There can be a few reasons for this problem:

 1. Incorrect DNS settings.

 2. Incorrect Time and Time zone settings.

 3. The "TCP/IP NetBIOS Helper" service isn't running.

 4. The "Remote Registry" service isn't running.

I have checked all of these and file and print sharing and still get the error.


Check it is accessible the Domain controller by \\<domain Controller>
Check the date, time and Time Zone
Check if any AV/firewall is blocking the traffic(software/hardware) or any traffic filtering device block the traffic

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.