2

I have installed solr 6.4.0 on ubuntu 16.04 LTS and want to use a configuration previously used on solr CLOUD 5.2.1

After creating a new core and linking the config files I can now see the core on the web interface and the files correctly under the core's administration interface.

The update link is greyed out and upon clicking on it it displays the error message:

Sorry, no dataimport-handler defined!

The things I checked:

  1. Solrconfig loads jar:

<lib dir="${solr.install.dir:../../../..}/dist/" regex="solr-dataimporthandler-.*\.jar" /> <lib dir="/usr/share/java/" regex="mysql-connector-java-.*\.jar" />

Seems to work, as it displays an error message upon changing the filename. I therefore assume the mysql connector is loaded

  1. Defined dataimport handler:

in solrconfig:

<requestHandler name="/dataimport" class="org.apache.solr.handler.dataimport.DataImportHandler"> <lst name="defaults"> <str name="config">dataimport.xml</str> </lst> </requestHandler>

  1. Dataimporthandler itself

the file dataimport.xml is present and shows:

<dataConfig>
<dataSource type="JdbcDataSource"
            driver="com.mysql.jdbc.Driver"
            url="jdbc:mysql://localhost:3306/test"
            user="solr"
            password="secret" 
            convertType="true"
            batchSize="-1"
            encoding="UTF-8" />
 ...

The logfile inside the webadmin does not show any errors. I assume that logging is not configured to display this kind of error.

When I change the password inside dataimport.xml or the db name, nothing different happens. Same error message.

Any ideas on how to narrow down the problem?

  • I have the same problem in previously i used 6.3.0 – Mihai Jan 26 '17 at 14:25
  • Does not look different to me except of the full path to the file?! wiki.apache.org/solr/DataImportHandler – merlin Jan 26 '17 at 15:27
  • The full path is not the problem. Tried it, same result. – merlin Jan 26 '17 at 16:43
  • Try doing this. It should work. – Aayush Gupta Feb 28 '18 at 14:55
3

Looks like the issue is in the Admin UI, if you send the straight dataimport request you get the expected response.

There is a Bug for this on the Apache Jira site and a fix

https://issues.apache.org/jira/browse/SOLR-10035

| improve this answer | |
  • Thank you! This solved the issue. Changed following file: solr/server/solr-webapp/webapp/js/angular/controllers/dataimport.js The string "QUERYHANDLER" to "QUERY". Unfortunatlly still no import luck due to "unable to execute query" but that is another storry. – merlin Jan 28 '17 at 11:22
  • Make sure you delete your browser's cache (or load in chrome's incognito mode) after making that change or you'll tear you hair out trying to figure out why it didn't fix your problem (I speak from experience) – Featherlegs Feb 8 '17 at 18:11
0

i just downgraded to 6.3.0 and its working... seems like there are some changes for 6.4.0 with regards to dataimport handler

| improve this answer | |
  • Doesn't a workaround help here? – chicks Jan 26 '17 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.