1

I'm using backuppc on debian wheezy, the backup service never completes the first initial backp. I keep getting the "Parent read EOF from child: fatal error!" error. Tried to look it up, doesn't seem to tell me much about my problem. Tried nearly every solution on google. I'm very close to giving up on backuppc.

So my question is not only how to fix it, but also "should I try another backup software"? rsnapshot didn't work for me. I basically need the simplest form of incremental backup software.

2

Assuming you already increased timeouts, etc, and with no other prior information on your setup, probably there are some very large files on the remote end (each larger than 2Gb) which breaks the flow.

Try excluding that/those file(s) through the web interface:

Edit Config -> Xfer -> BackupFilesExclude

I have been loking for alternatives to backuppc for a long time, but it still is by far the most dependable I found. It can be frustrating to set up for some machines, but then is basically a sen-and-forget appliance.

1
  • Hey, it does seem to be the problem. But for some reason the exclude files doesn't seem to work. I've googled it and tried multiple styles of config, but backuppc seems to ignore anything I try – Sniffleh Feb 25 '17 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.