7

On Windows 10 and SSMS 2016, I can no longer start SSMS as another user. I need to be able to do this in order to use trusted authentication to connect to some of my databases. This used to work fine, but using Windows 7 and an older version of SSMS.

If I right-click on the icon and choose 'run as a different user', I now get this

enter image description here

Is there a workaround for this?

Thanks

  • If you click "restart under different credential", does it actually work ? – yagmoth555 Feb 2 '17 at 4:31
  • Is that a different option to "Run as a different user"? That's what I've been doing and I get the error above. A colleague who has the same setup (Windows 10) gets exactly the same problem too. Looks like a genuine bug: connect.microsoft.com/SQLServer/feedback/details/3009405/… – Richard Feb 2 '17 at 9:49
  • I think you found the corresponding bug report, as it's unresolved, you could post it as an answer, and downgrade your windows 10 from 1607's build as a workaround. – yagmoth555 Feb 2 '17 at 18:19
  • Yup, thanks for the advice. I've gone back to using the SSMS 2014 which still works fine on Windows 10 rather than downgrading Windows, but either would work (I expect). – Richard Feb 2 '17 at 22:54
8

In case it helps anyone, I got it working by:

  • Open the location to the shortcut, such as: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Microsoft SQL Server Tools 17
  • Right-click > Properties > Compatibility >
  • Select "Run this program as an administrator"
  • Select the button "Change settings for all users" (THIS IS IMPORTANT)
  • Again, select "Run this program as an administrator"
  • Select "Okay", and 'Okay" again.

Hope it helps everyone.

| improve this answer | |
  • Strangely enough, this works when the equivalent CMD.EXE commands do not. I.e. if I want to run SSMS.exe as another user, I should be able to use "RUNAS" and powershell to launch as Administrator for another user. However, this causes SSMS to crash - only this solution has worked so far. – Coruscate5 Jun 4 '17 at 22:41
  • Didn't work for me...Using SSMS v17.9, Windows 10. – Gabrielius Oct 25 '18 at 11:47
2

Seems to be a known (unresolved) bug:

https://connect.microsoft.com/SQLServer/feedback/details/3009405/ssms-2016-fails-on-windows-10-version-1607-while-trying-to-execute-it-as-a-different-domain-user

SSMS 2014 still works fine so that's a workaround, or as @yahmoth555 suggested, use a different build of Windows.

| improve this answer | |
0

In windows 10 with ssms2018 installed it is little bit tricky.

you need to reach out the application setup file(.exe) (not shortcut) of SSMS and then press SHIFT + Right Click.

Here you go! there you will see a option "run as different user "

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.