0

We've had this issue for a while now and im at my whits end.

Bit of background, we have a simple setup, we have a main vlan for the office, then a few seperate ones for development, testing and support. Two windows server 2012 DC's running DHCP.

The issue I have is that the products we are developing will NOT get an DHCP assigned IP address from DHCP server when on the dev, test or support vlans. Yet we have no issue with them on the office vlan (also no issues when we have tested them on home networks, we also have roughly 20,000 diffferent units world wide and no one else has complained, so its not a unit issue). When I plug any computer into the test, dev or support networks it gets assigned the DHCP address. I can also set a static IP on one of our units and it is available on the network.

I am just looking for anything to try, I am thinking its something to do with the switch configuration, but I am still learning the ins and outs of the HP Procurves/networking and with the laptop picking up the DHCP address its a little bit limiting.

Thanks in advance.

Edit to add HP Procurve config

Running configuration For the Main Switch

; J9145A Configuration Editor; Created on release #W.15.14.0012
; Ver #06:04.18.63.ff.35.05:b6
hostname "Office"
module 1 type j9145a
module 2 type j9165a
no qos dscp-map af31
qos dscp-map ef priority 6
qos device-priority 10.54.0.10 priority 6
qos protocol arp priority 4
qos type-of-service diff-services
timesync sntp
sntp unicast
sntp server priority 1 172.16.0.4
sntp server priority 2 172.16.0.5
no stack auto-join
no telnet-server
ip dns domain-name "doman.co.uk"
ip dns server-address priority 1 10.54.4.110
ip dns server-address priority 2 10.54.4.100
ip route 0.0.0.0 0.0.0.0 10.54.31.1
interface 7
disable
exit
interface 8
disable
exit
interface 14
disable
exit
interface 15
disable
exit
interface 16
disable
exit
interface 18
disable
exit
interface 19
disable
exit
interface 20
disable
exit
interface A1
disable
exit
interface loopback 1
ip address 10.54.31.254
exit
snmp-server community "domain" operator
router rip
no auto-summary
redistribute connected
redistribute static
enable
exit
vlan 1
name "Old vlan"
no untagged 13,17,21
untagged 1-12,14-16,18-20,22-24,A1-A2
ip address 192.168.80.210 255.255.255.0
ip helper-address 10.54.4.100
exit
vlan 10
name "Office"
untagged 17
tagged 23-24
ip address 10.54.0.1 255.255.255.0
ip helper-address 10.54.4.100
ip helper-address 10.54.4.110
exit
vlan 20
name "Demo"
tagged 1-4,9-12
ip address 10.54.4.1 255.255.255.0
exit
vlan 40
name "DEV"
tagged 24
ip address 10.54.6.1 255.255.255.128
ip helper-address 10.54.4.100
exit
vlan 41
name "Support"
tagged 24
ip address 10.54.6.129 255.255.255.128
ip helper-address 10.54.4.100
exit
vlan 42
name "DEV_2"
tagged 24
ip address 10.54.7.1 255.255.255.128
ip helper-address 10.54.4.100
exit
vlan 43
name "TRN_ROOM"
tagged 23-24
ip address 10.54.8.1 255.255.255.0
ip helper-address 10.54.4.100
exit
vlan 100
name "Switch Vlan"
untagged 21
ip address 10.54.31.2 255.255.255.252
exit
vlan 101
name "Wireless Bridge link"
tagged 24
ip address 10.54.31.129 255.255.255.248
ip rip 10.54.31.129
exit
vlan 200
name "Backup internet for testing vlan"
untagged 13
tagged 24
no ip address
exit
no tftp server
no autorun
no dhcp config-file-update
password manager

Running Config for Office Switch

; J9280A Configuration Editor; Created on release #Y.11.44

hostname "titan"
no telnet-server
ip default-gateway 10.54.0.1
sntp server 172.16.0.4
sntp server 172.16.0.5
timesync sntp
sntp unicast
snmp-server community "Domain" Operator
vlan 1
name "Old VLAN"
untagged 45,48
no ip address
no untagged 1-44,46-47
ip igmp
exit
vlan 40
name "DEV"
untagged 29-31
ip address 10.54.6.1 255.255.255.128
tagged 46,48
exit
vlan 10
name "Office"
untagged 1-25,32-43,46
ip address 10.54.0.240 255.255.255.0
tagged 48
exit
vlan 101
name "Wireless BRIDGE"
untagged 47
tagged 48
exit
vlan 41
name "Support"
untagged 27-28
tagged 46,48
exit
vlan 200
name "Backup internet for testing vlan"
untagged 44
tagged 48
exit
vlan 42
name "DEV_2"
untagged 26
tagged 46,48
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
no fault-finder too-long-cable
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
spanning-tree
ip ssh
password manager

  • So when you plug a (physical?) machine into the VLAN, it does get a DHCP address, but other machines plugged into the same VLAN do not? – mzhaase Jan 31 '17 at 12:14
  • Hi @mzhasse Laptops and desktops get address's but our equipment does not. – Russell Feb 1 '17 at 8:49
  • Well what is 'equipment'? Virtual machines, servers, NAS? If some machines get DHCP and others on the same VLAN do not get DHCP, it is not a DHCP server error. It is something about those machines that are not getting it. Either they are configured the wrong way or something else is different. You do not give enough information to troubleshoot the issue. – mzhaase Feb 1 '17 at 9:04
  • They are AMP's, cinema systems things like that – Russell Feb 2 '17 at 8:44
  • Do they get an IP if you put them on the same VLAN as the DHCP servers? – mzhaase Feb 2 '17 at 11:47
0

For correct allocation, machines must be plugged into the correct VLAN and the switch ports must belong to the correct VLAN. Switch configuration may conflict at VLAN / port assignment level. Check the configurations of the switches.

  • Hi @Overmind Thanks for the reply, I would of thought that if the switch configuration was wrong the computer that gets plugged in wouldn't work. If you have a good switch knowledge I would be greatful if you would look through the switch config. – Russell Feb 1 '17 at 8:48
  • Sure, if it's a CISCO post the output from the enabled prompt - imput the command: show vlan . That will show you what ports are assigned to what VLAN. If it's something like HP or Zyxel, it has a graphical interface and you can check VLAN allocation there on VLAN tab. – Overmind Feb 1 '17 at 10:51
  • I have added the config to the main question – Russell Feb 2 '17 at 9:19
  • Now, in the VLANs section, check if the ports you are connecting to and having problems with belong to the correct VLAN (example: port 12 may be needed in the Office VLAN instead of the default old one). – Overmind Feb 3 '17 at 6:22
  • Hi Overmind, the ports are correct, the old default one has been left as the "Office" switch is with the servers. – Russell Feb 3 '17 at 8:43
0

The problem is that DHCP is a LAN protocol (uses broadcast), and the server and hosts must be on the same LAN for normal operation.

The solution is to use DHCP relay on your gateway device (router). You also need to make sure that the DHCP server has scopes for the other networks on the other VLANs.

  • Hi @Ron Maupin, Thanks for the reply, all the DHCP scopes are set on the server for each VLAN. The confusing part is that a computer can get a DHCP address. – Russell Feb 1 '17 at 8:45
  • Yes, as Ron said though you need to configure 'DHCP Helper' service on your router/s. – Chopper3 Feb 2 '17 at 9:29
  • If you look at the above config you will see that the IP address helper has been added. – Russell Feb 3 '17 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.