1

I'm trying to move the last few databases off an older mysql server, but one in particular has me stumped:

ERROR 1118 (42000) at line 595: The size of BLOB/TEXT data inserted in one transaction is greater than 10% of redo log size. Increase the redo log size using innodb_log_file_size.

The server being migrated to is running 5.6.29-76.2-log Percona Server, which appears to have a workaround for a transactional consistency bug with large BLOBs.

Since modifying innodb_log_file_size requires a service restart, is there a way to import a database with transactions disabled or something? SQL*Loader has a number of options for disabling transactions on an import, maybe there's a similar tool & setting for MySQL?

1

There's no workaround, here. You'll need to restart.

Everything in InnoDB is done in a transaction. Sometimes it's an implicit one (when autocommit is enabled, each statement executed -- technically -- starts and commits its own transaction) but it's still a transaction in the relevant sense.

The redo log is a critical component, and can only be resized with a restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.