I have an Ubuntu virtual machine on Azure. This machine has only one disk attached, the OS Disk. I created a backup vault for this server, and the backup runs every night at 2AM.

This server is bound to be production soon, so I set about testing the backup system.

The backup looks successful: I have 30 restore points for the last month, each marked as "File System Consistent").

I tried a restore today. So I deleted a few things from the database (it's fine, it's not on prod yet), and tried restoring the backup from yesterday, using "Restore disk".

Azure tells me the restore is successful, yet the data I deleted is not back. I even rebooted the virtual machine, to no effect.

What am I missing?

  • Reading todays horror story, kudos to you for testing that backup :) – Sven Feb 1 '17 at 11:18
  • Yeah, I have to say it was a good reminder :) – aspyct Feb 1 '17 at 11:52
  • share the same frustration. Contacting 'em on the issue. Documentation sucks, clustering all over the place with both 'classic' and 'new'. urgh... – Nathan Do Feb 14 '17 at 17:26
  • Yup, agreed! As it turns out, I managed to rebuild the VM by creating a new one, instead of just restoring the disk. Eh wait a second, that might explain why my storage cost increased badly recently! – aspyct Feb 14 '17 at 22:42
  • yeah that works but then that also means you need to reserve an ip and then attach it to new vm on real time + delete the old one. @$%^& – Nathan Do Feb 15 '17 at 2:42

Well this was a long time ago now, but I eventually figured it out. If I remember properly, the disk was restored, but was created as a new disk. I guess I would have to attach the new disk to the VM and remove the old one.

Be careful with this restore though. As it creates new disks, your hosting costs will increase.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.