-1

I'm attempting to connect to a Windows Server 2008 R2 through Amazon EC2 on my Windows 7 PC. However each time I try to launch the instance using Remote Desktop Connection the following error comes up:

Remote Desktop can't connect to the remote computer for one of these reasons:
1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network

When I created the instance, all the settings were left as the default. I believed it may have something to do with the network blocking the connection, but Remote Access is enabled on this PC and the firewall is allowing Remote Access (although that could be incoming, not outgoing and I've made a mistake).

Any ideas on how this could be fixed?

  • Check if RDP is enabled on the server. – Orphans Feb 2 '17 at 11:44
  • 1
    Please check with telnet host-pc 3389 if the Server answer to the right port. – Zwiebackjunge Feb 2 '17 at 14:26
  • 1
    As a basic troubleshooting step, you coudl try it with the firewall off. – batistuta09 Feb 2 '17 at 14:35
0

Check in your inbound rules of security group associated with EC2 instance if you have a rule allowing RDP connections, if not add rule and try again.

| improve this answer | |
0
Goto Security Groups -> Inbound and choose RDP from the list.

In the Source field, add your IP or allow connections from all IPs with 0.0.0.0

Save the rule and try connecting your EC2 instance again.

Any outbound setting you do will have no effect on you connecting to that instance.

| improve this answer | |
  • If this doesn't work, then try rebooting the instance and make sure the instance state is running before you try to connect again. – Azfar Ullah Khan Feb 2 '17 at 16:09
  • I have tried both of those options and tried to connect still the same error appears. – HockeyAdam Feb 2 '17 at 16:54
0

Check if your public IP address has not changed. Probably you are using dynamic IP settings on your instance

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.