1

I have a Xeon-based Dell T20 with Quad Intel I350 running Windows Server 2016 Hyper-V with OpenSUSE as Gen2 VM. Both Windows Server and OpenSUSE have dedicated ports on I350, no sharing. SR-IOV is enabled on all NIC's ports and Hyper-V virtual switch as well. VMQ is enabled, all offload options are enabled, no jumbo frames, no VLAN set but VLANs are enabled. EEE is disabled.

The problem is, when I run iperf3 from another box to Windows Server, I get 940MBit/s on average both ways, and when iperf3 is running against OpenSUSE VM, throughput never goes above 130MBit/s regardless of direction.

No CPU spikes during test thus I assume the problem is not a lack of CPU power.

Is those 130 MBit/s is the greatest speed I can get to/from VM?

Update 1: Switch Properties:

Name                                : LanIOV
Id                                  : 881379d9-2030-4a08-8594-2f3001ee2a55
Notes                               : 
Extensions                          : {Microsoft Windows Filtering Platform, Microsoft Azure VFP Switch Extension, Micr
                                  osoft NDIS Capture}
BandwidthReservationMode            : None
PacketDirectEnabled                 : False
EmbeddedTeamingEnabled              : False
IovEnabled                          : True
SwitchType                          : External
AllowManagementOS                   : False
NetAdapterInterfaceDescription      : Intel(R) Ethernet Server Adapter I350-    T4 #4
NetAdapterInterfaceDescriptions     : {Intel(R) Ethernet Server Adapter     I350-T4 #4}
IovSupport                          : False
IovSupportReasons                   : {SR-IOV cannot be used on this system as the PCI Express hardware does not suppor
                                      t Access Control Services (ACS) at any root port. Contact your system vendor for 
                                      further information., SR-IOV cannot be used on this network adapter as the PCI Ex
                                      press hardware does not support Access Control Services (ACS). This device may wo
                                      rk in an alternate PCI Express slot. Contact your hardware vendor for further inf
                                      ormation.}
AvailableIPSecSA                    : 0
NumberIPSecSAAllocated              : 0
AvailableVMQueues                   : 7
NumberVmqAllocated                  : 3
IovQueuePairCount                   : 0
IovQueuePairsInUse                  : 0
IovVirtualFunctionCount             : 0
IovVirtualFunctionsInUse            : 0
PacketDirectInUse                   : False
DefaultQueueVrssEnabledRequested    : True
DefaultQueueVrssEnabled             : True
DefaultQueueVmmqEnabledRequested    : False
DefaultQueueVmmqEnabled             : False
DefaultQueueVmmqQueuePairsRequested : 16
DefaultQueueVmmqQueuePairs          : 4
BandwidthPercentage                 : 0
DefaultFlowMinimumBandwidthAbsolute : 0
DefaultFlowMinimumBandwidthWeight   : 0
CimSession                          : CimSession: .
ComputerName                        : SERVER
IsDeleted                           : False
  • Is those 130 MBit/s is the greatest speed - nope, I get the full speed on My Linux VMs. How have you configured your vmswitch and team? – Zoredache Feb 2 '17 at 16:37
  • No teaming, vmswitch's settings are all default except for physical NIC, sharing off and SR-IOV on. There are two more VMs bound to the switch yet they're off at the time of testing. Any idea what have I missed here? – Alex Seleznyov Feb 2 '17 at 17:51
  • Why do you have SR-IOV on? Do you really need to assign a port directly to a VM? You said you don't have teaming, so do you only have a single port of that network adapter attached to the switch? Are you using the Switch embedded teaming? What does the output of Get-VMSwitch | Format-List look like? – Zoredache Feb 2 '17 at 17:57
  • SR-IOV - was off when I run into that issue. Enabled to see if it helps. Direct port - same reason. Ports - no, both Window Server's and VM's are attached to the switch. Two cables. Ports work independently, like simple NICs. Get-VMSwitch output added to original question. – Alex Seleznyov Feb 2 '17 at 20:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.