0

I created a new Rational Software Architect workspace pointing to an existing WAS/WebSphere Portal 8.5 profile.

Everything builds without an error, I launch the server, no errors.

However when I try to log in as an administrator, after entering username and password, I am prompted with a download.gz file download which contains the header of the welcome web page.

I click refresh and can reach the "Welcome to WebSphere Portal Administration" page, but once again every link I click prompts me with a file download.

When I go back to the logs, it stack traces something awful, with: com.ibm.wps.engine.Servlet handleException EJPEJ0070E: java.lang.NoSuchMethodError: com/bombardier/web/common/WCMUtil.getCategoryUUIDs(Ljava/util/List;)Ljava/util/List;

Also get EJPEI0175E mentioning the custom theme that is used. It is clearly theme related.

I spent the day without figuring it out. Any help greatly appreciated !

Best regards, Bert

0

Found the answer.

The application had some projects that were shared libraries that needed to be exported as jars and placed under PortalServer/shared/app

The Portal then had to be restarted.

The IBM reference is here: https://www-10.lotus.com/ldd/portalwiki.nsf/xpDocViewer.xsp?lookupName=IBM+Redbooks%3A+Managing+WebSphere+Portal+6.1+Environments#action=openDocument&res_title=P61t2h&content=pdcontent

Hope this saves someone some grief.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.