0

UPDATE: I completely commented out the rc.local script and the problem still persists. This time though, it seems like the boot process has made it further than before. It's still getting hung though. I don't have enough rep to post a photo. But it seems to hang right after User Manager starts. UID 128. Still completely unsure what could be causing this. I certainly hope I don't have to wipe again. The darn thing has only existed for 2 days!

I have an ubuntu-server (16.10) that I use as to host various things including a webserver, teamspeak, and vnc.

I would like to note that this is my first time using the Ubuntu platform as a stand-alone server, previously I was using a windows machine but wanted to switch for performance reasons. Anyways, I have the server configured to execute it's rc.local script at the end of the startup sequence. I have ubuntu-desktop installed, which is also configured to execute immediately after rc.local. I am mostly a novice when it comes to navigating Ubuntu via the terminal, but I can manage without too much of an issue.


I found the script to not be the issue, but below is some information regarding it.


The problem began after I installed a teamspeak server and entered it's boot into the rc.local script. The server will boot, the screen will show nice, green OK!'s most of the way, then it gets to my script that only launches apache and TS3. It launches apache fine, then right after it says

Teamspeak Server Started 

it stops. Just a cursor that's not even blinking. I cannot CTRL-ALT F1 or type any commands.

At first it threw error codes that stated a permissions issue with one of my SQL server's files. It stated:

World-writable config file: /opt/lampp/etc/my.conf Ignored

To which I loaded up a repair disk and chmod 644'd and now that error is fixed.

Here's the best part though. The server is running! It is by no means 'frozen' as I can still access the webserver, and the teamspeak server.

So what are your thoughts? I have attached a rough copy of the startup script below. I do not have direct access to it unless I boot up the repair disk again.

#bin/bash/
/opt/lampp/lampp start

echo 'Xampp Servers Successfully Started!'

/opt/ts3/teamspeak3-startup-script.sh start

echo 'Teamspeak 3 Successfully Started!'

exit 0

edit: I ran the repair disk and the script above is a near-exact copy of the rc.local script. It does have an exit 0 at the end but it still hangs.

0

You are right to ask about requiring an exit 0: you do.

Debian, Ubuntu, or RHELs rc.local need an exit 0, otherwise your boot process would get stuck. I remember noticing cron didn't start (at least on non-systemd versions), missing that last line.

The only exception I know of would be FreeBSD, where exit 0 is not required.

Can you get in with ssh? You should be able to fix/reboot.

  • I don't have ssh access. I will go run the repair disk and modify the startup script and get back. Thank you – Bradyn Claycomb Feb 4 '17 at 1:34
  • I ran the repair disk, and looked at the file. (Its rc.local, not rc.inital. My bad) The script DOES have exit 0 but still seems to have problems booting. I updated the original post accordingly – Bradyn Claycomb Feb 4 '17 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.