2

I am trying to mount a windows samba share on CentOS and RHEL 6 machines, but gives following error.

~]# mount.cifs //example.com/Linux_Support /mnt -o credentials=/root/cifsauth,noserverino,vers=3.0

mount error(112): Host is down Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Messages logs has this error:

CIFS VFS: cifs_mount failed w/return code = -112

The same above command works in rhel7 and centos7. Any clue on how to make this work?

  • I assume its fully updated and you can ping the host from the RHEL6 machine? What is the version of cifs-utils installed? – mzhaase Feb 6 '17 at 11:22
  • yes, rhel 6 and centos 6 is at latest updates for all packages and I am able to ping as well. They are all in same network range. mount.cifs version: 4.8.1 – Arun Krishnan Feb 7 '17 at 7:43
  • Could there be any version issue with cifs utils and the samba share from windows? – Arun Krishnan Feb 8 '17 at 4:03
  • Maybe? You could try to do it as root, use SMB2, or do an strace. – mzhaase Feb 8 '17 at 7:24
3

I found this link here which says SMB 2 and 3 is not supported for rhel and Centos 6. It can only mount SMB1. From Centos and rhel 7 this is supported.

1

I solved this problem by forcing version 1 of the smb protocol.
In my fstab this is done like this:

//192.168.0.XXX/elements/Videos /home/myuser/videos cifs uid=1000,username=myuser,password=mypwd,rw,nounix,noserverino,defaults,auto,vers=1.0 0 0

By default, the system certainly use SMB2 or 3, and it doesn't work with my box. In fact it depends on your NAS. You have to give the good version depending on the SMB server.

0

First check the accessibility of your windows host in generally under centos6. If that is given then proceed.

At them moment, I dont have a test-setup to reproduce.I can only imagine. So maybe the default firewall-settings on your centos6 differs from the centos7 default firewall-settings. Did you try to mount with firewall switched off on your centos host? And what about SELinux? Maybe it has it fingers in it too.

  • I disabled firewall and selinux. The windows host is accessible and its not an issue with it because I am able to mount with same command and same host on centos7 – Arun Krishnan Feb 6 '17 at 10:37
0

My issue has been resolved by adding the ip address and hostname of windows server in /etc/hosts file in linux. then creating user in windows server with password. shared the folder with created user. created the file in /.smbcredentials adding following 2 lines

username=<username>
password=<password of user>

try to ping the windows machine with hostname it should ping. otherwise change windows firewall settings. now finally add the entry in fstab as below.

//hostname of windows/shared folder name /local folder on linux cifs credentials=/.smbcredentails,vers=3.0,sec=ntlm,iocharset=utf8,file_mode=0777,dir_mode=0777,gid=100 0 0

save the file and exit now run mount -av command you should get mounted successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.