9

after I installed VMware Tools on virtual machine its resolution adjusts to the console window size automatically. It is not what I want - I want that the resolution of my virtual machine stays the same.

It is VMware ESXi 6.5, where is only web console available.

It is happening only after installing VMware Tools (i need it of course).

Anyone knows how to turn it off ?

I tried to use some forums tips with setting: svga.MaxWidth/svga.MaxHeight parameters, but it doesn't work...

  • 4
    We are running automatic ui tests on vmware clients. When a remote console connects, often tests fail because the screen resolution gets too low and the test tool does not find controls. So I have the same problem, hereby adding a use case. – Moritz Both Nov 23 '17 at 14:59
  • Can you provide some additional information? What patch level are you running 6.5, are you using Flash or HTML5 browser, what about vmware player, what version of windows/linux. – Jacob Evans Nov 27 '17 at 20:34
  • I am using HTML5 browser. Automatic resolution change happens both with HTML5 Browser console and with plugin (vmrc) as well as with VMware Workstation connecting to the vSphere Server. vSphere Client Version 6.5.0.10000. The guests are mostly windows 7. The clients using the remote console are different Windows and Linux versions, but I think that does not matter since the resolution change is done by the vmware tools. – Moritz Both Nov 30 '17 at 11:45
  • General hint: The bounty expires in three hours. If anybody has a solution, I will gladly start another one :) – Moritz Both Nov 30 '17 at 11:51
  • 1
    How to disable auto-fitting of Windows guest OS screen resolution when accessing from Web Client and VMRC (52031) kb.vmware.com/s/article/52031 – Brad Sep 21 '18 at 15:09
2

Found a solution!!

Windows Client resolution changes work by calling <ProgramDir>\VMware\VMware Tools\VMwareResolutionSet.exe. After I renamed that file, bingo no more resolution changes. Obviously this works until the next VMware tools update only, but it does the job for us.

Since it is not easy to find, here is the reference for VMwareResolutionSet.exe from a random forum thread at https://kb.vmware.com/s/article/2058577

Run VMwareResolutionSet.exe to force Windows to set your desired resolution.

VMwareResolutionSet.exe Variable1 Variable2 , Variable3 Variable4 Variable5 Variable6

Variable 1 is the index of the primary monitor (Default = 0).

Variable 2 is the number of total monitors (Default = 1).

Variable 3 is the starting X position of monitor 0 (Default = 0).

Variable 4 is the starting Y position of monitor 0 (Default = 0).

Variable 5 is the width (X) of monitor 0 in pixels.

Variable 6 is the width (Y) of monitor 0 in pixels.

For Example, to set the virtual machine display resolution to 3280 x 2048:

VMwareResolutionSet.exe 0 1 , 0 0 3280 2048

The spaces around the comma seem to be significant.

1

Try using the html5 interface with the remote console plugin (VMRC) and set the resolution within the OS. That solved this issue for me, anyway.

A couple of tricks to getting the remote console plugin working correctly:

It likes to be run elevated. So after installing the remote console plugin, find the vmrc.exe file using Explorer, right click, select Properties -> Compatibility tab -> check the Change settings for all users option and Run this program as an administrator.

That should save you some additional headaches. There are known issues with the Flash client, and I even read somewhere that the Flash version is being discontinued at some point.

  • What do you mean when you say "set the resolution within the OS"? Every time you connect, that is? That's not an option. This does not help me with the problem. Also, running vmrc.exe elevated adds security risks and sorry, if vmware cannot tell me why this would be neccessary I won't do this. – Moritz Both Nov 30 '17 at 11:49
  • Sorry for such a delayed response. Holidays and all that. Since you did not specify which operating system you installed, I can only give examples. In windows, right click and select display settings to set the resolution. I suggest editing your post to include the specific operating system you are having trouble with. – Bill Jan 12 '18 at 19:06
  • 1
    It is changed back on every connect. This is what op (and me) wanted to avoid afaik. – Moritz Both Jan 16 '18 at 14:19
0

We had the same issue. Turns out that in the VM settings the video card setting was 'custom'. If you change that to 'auto-detect settings' the problem goes away! You can only change this if the VM is powered off. Unless you need custom settings for a specific reason, this works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.