0

I wanted to hide GRUB during boot, so that I can access the list of OS whenever I want to boot something other than the default. I hid GRUB by specifying in /etc/default/grub that

GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=0

The problem is now that whenever I press the shift key duing boot, Loading grub is printed , but then quickly thereafter loads the OS without giving me an option to select OS.

Question

Now that I cannot get into grub using the shift key, how can I get into debian to change the settings?

2

You can boot your system from a Debian installation disk, choosing the Rescue option.

From there, you should be asked if you want to to open a shell on your original Debian file system, so you can edit /etc/default/grub file and then run update-grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.